# CVE-2026-24891: openITCOCKPIT has Unsafe PHP Deserialization in Gearman Worker Allowing Conditional Object Injection

> Attackers can execute arbitrary code via unsafe PHP deserialization in the Gearman worker if network access is unrestricted.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-x4mq-8gfg-frc4

## What is CVE-2026-24891?

CVE-2026-24891 is a high-severity unsafe deserialization vulnerability in openITCOCKPIT, published on 20 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

openITCOCKPIT is an open source monitoring tool built for different monitoring engines like Nagios, Naemon and Prometheus. Versions 5.3.1 and below contain an unsafe deserialization sink in the Gearman worker implementation. The worker function registered as oitc_gearman calls PHP's unserialize() on job payloads without enforcing class restrictions or validating data origin. While the intended deployment assumes only trusted internal components enqueue Gearman jobs, this trust boundary is not enforced in application code. In environments where the Gearman service or worker is exposed to untrusted systems, an attacker may submit crafted serialized payloads to trigger PHP Object Injection in the worker process. This vulnerability is exploitable when Gearman listens on non-local interfaces, network access to TCP/4730 is unrestricted, or untrusted systems can enqueue jobs. Default, correctly hardened deployments may not be immediately exploitable, but the unsafe sink remains present in code regardless of deployment configuration. Enforcing this trust boundary in code would significantly reduce risk and prevent exploitation in misconfigured environments. This issue has been fixed in version 5.4.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-24891?

It affects 1 product.


Products: It-Novum Openitcockpit.

## How do I fix CVE-2026-24891?

No fix has been published for CVE-2026-24891 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-24891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24891 exists.

## Other vulnerabilities in openITCOCKPIT

- [CVE-2020-10789](https://insights.sbomify.com/CVE-2020-10789/): Command injection in n/a (critical 9.8)
- [CVE-2019-15490](https://insights.sbomify.com/CVE-2019-15490/): Code injection in n/a (critical 9.8)
- [CVE-2019-15494](https://insights.sbomify.com/CVE-2019-15494/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2020-10788](https://insights.sbomify.com/CVE-2020-10788/): Hardcoded credentials in n/a (critical 9.1)
- [CVE-2026-24893](https://insights.sbomify.com/CVE-2026-24893/): openITCOCKPIT has Authenticated Command Injection Leading to Remote Code Execution via Host Address Macro Expansion (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24891 and fix it if it is affected.

What it is: CVE-2026-24891 is a high-severity unsafe deserialization vulnerability in openITCOCKPIT, published on 20 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24891 exists.

Affected product: openITCOCKPIT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24891/ (Markdown: https://insights.sbomify.com/CVE-2026-24891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24891
- OSV: https://osv.dev/vulnerability/CVE-2026-24891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24891/
Summaries are generated and may contain mistakes; the official description above is the record.
