{"answers":{"affected":"3 open source packages ship an affected version, including github.com/dunglas/frankenphp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24894 in the wild and no public exploit code.","fix":"Upgrade github.com/dunglas/frankenphp to 1.11.2 or later.","what":"CVE-2026-24894 is a high-severity vulnerability in frankenphp, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24894 and fix it if it is affected.\n\nWhat it is: CVE-2026-24894 is a high-severity vulnerability in frankenphp, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24894 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2\n- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2\n- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24894/ (Markdown: https://insights.sbomify.com/CVE-2026-24894/index.md)","id":"CVE-2026-24894","markdown":"https://insights.sbomify.com/CVE-2026-24894/index.md","name":"CVE-2026-24894","record":{"aliases":["GHSA-r3xh-3r3w-47gp","GO-2026-4489"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP application server","requires_auth":"none","summary":"Attackers can access other users' session data in FrankenPHP worker mode due to improper session reset between requests.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"frankenphp","vendor":"php"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"},{"id":"CWE-384","name":"Session Fixation"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"FrankenPHP is a modern application server for PHP. Prior to 1.11.2, when running FrankenPHP in worker mode, the $_SESSION superglobal is not correctly reset between requests. This allows a subsequent request processed by the same worker to access the $_SESSION data of the previous request (potentially belonging to a different user) before session_start() is called. This vulnerability is fixed in 1.11.2.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FrankenPHP leaks session data between requests in worker mode","id":"CVE-2026-24894","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"FrankenPHP affected by Path Confusion via Unicode casing in CGI path splitting allows execution of arbitrary files","id":"CVE-2026-24895"},"packages":[{"ecosystem":"Go","fixed":["1.11.2"],"introduced":["0"],"last_affected":[],"package":"github.com/dunglas/frankenphp","purl":null,"source":"GHSA-r3xh-3r3w-47gp"},{"ecosystem":"Go","fixed":["1.11.2"],"introduced":["0"],"last_affected":[],"package":"github.com/dunglas/frankenphp","purl":"pkg:golang/github.com/dunglas/frankenphp","source":"GHSA-r3xh-3r3w-47gp"},{"ecosystem":"Go","fixed":["1.11.2"],"introduced":["0"],"last_affected":[],"package":"github.com/dunglas/frankenphp","purl":"pkg:golang/github.com/dunglas/frankenphp","source":"GO-2026-4489"}],"prev":{"headline":"openITCOCKPIT has Authenticated Command Injection Leading to Remote Code Execution via Host Address Macro Expansion","id":"CVE-2026-24893"},"products":["frankenphp"],"published":"2026-02-12","related":[{"cvss_score":8.9,"headline":"FrankenPHP affected by Path Confusion via Unicode casing in CGI path splitting allows execution of arbitrary files","id":"CVE-2026-24895","kev_date_added":null,"published":"2026-02-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-12","vendors":["php"]},"summary":"Attackers can access other users' session data in FrankenPHP worker mode due to improper session reset between requests.","url":"https://insights.sbomify.com/CVE-2026-24894/"}