# CVE-2026-24894: FrankenPHP leaks session data between requests in worker mode

> Attackers can access other users' session data in FrankenPHP worker mode due to improper session reset between requests.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** GHSA-r3xh-3r3w-47gp, GO-2026-4489

## What is CVE-2026-24894?

CVE-2026-24894 is a high-severity vulnerability in frankenphp, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FrankenPHP is a modern application server for PHP. Prior to 1.11.2, when running FrankenPHP in worker mode, the $_SESSION superglobal is not correctly reset between requests. This allows a subsequent request processed by the same worker to access the $_SESSION data of the previous request (potentially belonging to a different user) before session_start() is called. This vulnerability is fixed in 1.11.2.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-384 (Session Fixation), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-24894?

3 open source packages ship an affected version, including github.com/dunglas/frankenphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.11.2 |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.11.2 |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.11.2 |

Products: Php Frankenphp.

## How do I fix CVE-2026-24894?

Upgrade github.com/dunglas/frankenphp to 1.11.2 or later.

## Is CVE-2026-24894 being exploited?

There is no known exploitation of CVE-2026-24894 in the wild and no public exploit code.

## Other vulnerabilities in frankenphp

- [CVE-2026-24895](https://insights.sbomify.com/CVE-2026-24895/): FrankenPHP affected by Path Confusion via Unicode casing in CGI path splitting allows execution of arbitrary files (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24894 and fix it if it is affected.

What it is: CVE-2026-24894 is a high-severity vulnerability in frankenphp, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24894 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24894/ (Markdown: https://insights.sbomify.com/CVE-2026-24894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24894
- OSV: https://osv.dev/vulnerability/CVE-2026-24894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24894/
Summaries are generated and may contain mistakes; the official description above is the record.
