# CVE-2026-24895: FrankenPHP affected by Path Confusion via Unicode casing in CGI path splitting allows execution of arbitrary files

> Attackers can execute arbitrary files by exploiting Unicode casing flaws in CGI path splitting, allowing unauthorized code execution on the server.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** GHSA-g966-83w7-6w38, GO-2026-4486

## What is CVE-2026-24895?

CVE-2026-24895 is a high-severity path traversal vulnerability in frankenphp, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FrankenPHP is a modern application server for PHP. Prior to 1.11.2, FrankenPHP’s CGI path splitting logic improperly handles Unicode characters during case conversion. The logic computes the split index (for finding .php) on a lowercased copy of the request path but applies that byte index to the original path. Because strings.ToLower() in Go can increase the byte length of certain UTF-8 characters (e.g., Ⱥ expands when lowercased), the computed index may not align with the correct position in the original string. This results in an incorrect SCRIPT_NAME and SCRIPT_FILENAME, potentially causing FrankenPHP to execute a file other than the one intended by the URI. This vulnerability is fixed in 1.11.2.

Weakness: CWE-180 (Incorrect Behavior Order: Validate Before Canonicalize)

## Which versions are affected by CVE-2026-24895?

3 open source packages ship an affected version, including github.com/dunglas/frankenphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.11.2 |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.11.2 |
| `github.com/dunglas/frankenphp` | Go | All versions | 1.11.2 |

Products: Php Frankenphp.

## How do I fix CVE-2026-24895?

Upgrade github.com/dunglas/frankenphp to 1.11.2 or later.

## Is CVE-2026-24895 being exploited?

There is no known exploitation of CVE-2026-24895 in the wild and no public exploit code.

## Other vulnerabilities in frankenphp

- [CVE-2026-24894](https://insights.sbomify.com/CVE-2026-24894/): FrankenPHP leaks session data between requests in worker mode (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24895 and fix it if it is affected.

What it is: CVE-2026-24895 is a high-severity path traversal vulnerability in frankenphp, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24895 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2
- github.com/dunglas/frankenphp (Go): affected all versions; fixed in 1.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24895/ (Markdown: https://insights.sbomify.com/CVE-2026-24895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24895
- OSV: https://osv.dev/vulnerability/CVE-2026-24895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24895/
Summaries are generated and may contain mistakes; the official description above is the record.
