# CVE-2026-24899: Fleet Windows MDM Azure AD JWT Authentication Bypass

> Attackers can bypass authentication in Fleet's Windows MDM by using tokens from any Azure AD tenant, enabling unauthorized device enrollment and access to sensitive data.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 16 May 2026
- **Also known as:** GHSA-ffg9-j72f-j6xm, GO-2026-5358

## What is CVE-2026-24899?

CVE-2026-24899 is a high-severity authentication bypass vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fleet is open source device management software. Prior to version 4.82.0, a vulnerability in Fleet's Windows MDM enrollment flow allows authentication tokens from any Azure AD tenant to be accepted. Because Fleet validates JWT signatures using Microsoft's multi-tenant JWKS endpoint but does not enforce the `aud` (audience) or `iss` (issuer) claims, any Microsoft-signed Azure AD access token containing the expected scopes can be used to authenticate to Fleet's MDM endpoints. If Windows MDM is enabled, an attacker with access to any Azure AD tenant can obtain a valid Microsoft-signed token and use it to enroll unauthorized devices and interact with Fleet's MDM management APIs. During device management, Fleet may expose sensitive enrollment secrets embedded in MDM command payloads, enabling further unauthorized access. Version 4.82.0 contains a patch. If an immediate upgrade is not possible, affected Fleet users should temporarily disable Windows MDM.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-24899?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.82.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.82.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.82.0 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-24899?

Upgrade github.com/fleetdm/fleet/v4 to 4.82.0 or later.

## Is CVE-2026-24899 being exploited?

There is no known exploitation of CVE-2026-24899 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24899 and fix it if it is affected.

What it is: CVE-2026-24899 is a high-severity authentication bypass vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24899 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.82.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.82.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.82.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24899/ (Markdown: https://insights.sbomify.com/CVE-2026-24899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24899
- OSV: https://osv.dev/vulnerability/CVE-2026-24899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24899/
Summaries are generated and may contain mistakes; the official description above is the record.
