# CVE-2026-24902: TrustTunnel has SSRF and private network restriction bypass via numeric address destinations

> Attackers can bypass private network restrictions and access internal services via numeric IP addresses in TrustTunnel when SSRF protection is enabled.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Jan 2026
- **Updated:** 29 Jan 2026
- **Also known as:** GHSA-hgr9-frvw-5r76

## What is CVE-2026-24902?

CVE-2026-24902 is a high-severity server-side request forgery vulnerability in TrustTunnel, published on 29 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TrustTunnel is an open-source VPN protocol with a server-side request forgery and and private network restriction bypass in versions prior to 0.9.114. In `tcp_forwarder.rs`, SSRF protection for `allow_private_network_connections = false` was only applied in the `TcpDestination::HostName(peer)` path. The `TcpDestination::Address(peer) => peer` path proceeded to `TcpStream::connect()` without equivalent checks (for example `is_global_ip`, `is_loopback`), allowing loopback/private targets to be reached by supplying a numeric IP. The vulnerability is fixed in version 0.9.114.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-24902?

It affects 1 product.


Products: Adguard Trusttunnel.

## How do I fix CVE-2026-24902?

No fix has been published for CVE-2026-24902 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-24902 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24902 exists.

## Other vulnerabilities in TrustTunnel

- [CVE-2026-24904](https://insights.sbomify.com/CVE-2026-24904/): TrustTunnel has `client_random_prefix` rule bypass via fragmented or partial TLS ClientHello (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24902 and fix it if it is affected.

What it is: CVE-2026-24902 is a high-severity server-side request forgery vulnerability in TrustTunnel, published on 29 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24902 exists.

Affected product: TrustTunnel. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24902/ (Markdown: https://insights.sbomify.com/CVE-2026-24902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24902
- OSV: https://osv.dev/vulnerability/CVE-2026-24902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24902/
Summaries are generated and may contain mistakes; the official description above is the record.
