# CVE-2026-24905: Inspektor Gadget has a Command Injection vulnerability in Makefile.build

> An attacker controlling gadget manifest options can execute arbitrary commands on the host or build container during image building.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2026
- **Updated:** 30 Apr 2026
- **Also known as:** GHSA-79qw-g77v-2vfh, GO-2026-5211

## What is CVE-2026-24905?

CVE-2026-24905 is a medium-severity command injection vulnerability in inspektor-gadget, published on 29 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Inspektor Gadget is a set of tools and framework for data collection and system inspection on Kubernetes clusters and Linux hosts using eBPF. The `ig` binary provides a subcommand for image building, used to generate custom gadget OCI images. A part of this functionality is implemented in the file `inspektor-gadget/cmd/common/image/build.go`. The `Makefile.build` file is the Makefile template employed during the building process. This file includes user-controlled data in an unsafe fashion, specifically some parameters are embedded without an adequate escaping in the commands inside the Makefile. Prior to version 0.48.1, this implementation is vulnerable to command injection: an attacker able to control values in the `buildOptions` structure would be able to execute arbitrary commands during the building process. An attacker able to exploit this vulnerability would be able to execute arbitrary command on the Linux host where the `ig` command is launched, if images are built with the `--local` flag or on the build container invoked by `ig`, if the `--local` flag is not provided. The `buildOptions` structure is extracted from the YAML gadget manifest passed to the `ig image build` command. Therefore, the attacker would need a way to control either the full `build.yml` file passed to the `ig image build` command, or one of its options. Typically, this could happen in a CI/CD scenario that builds untrusted gadgets to verify correctness. Version 0.51.1 fixes the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-24905?

3 open source packages ship an affected version, including github.com/inspektor-gadget/inspektor-gadget. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/inspektor-gadget/inspektor-gadget` | Go | All versions | 0.51.1 |
| `github.com/inspektor-gadget/inspektor-gadget` | Go | All versions | 0.51.1 |
| `github.com/inspektor-gadget/inspektor-gadget` | Go | All versions | 0.51.1 |

Products: Linuxfoundation Inspektor Gadget.

## How do I fix CVE-2026-24905?

Upgrade github.com/inspektor-gadget/inspektor-gadget to 0.51.1 or later.

## Is CVE-2026-24905 being exploited?

There is no known exploitation of CVE-2026-24905 in the wild and no public exploit code.

## Other vulnerabilities in inspektor-gadget

- [CVE-2026-25996](https://insights.sbomify.com/CVE-2026-25996/): Inspektor Gadget uses unsanitized ANSI Escape Sequences In `columns` Output Mode (medium 6.9)
- [CVE-2026-31890](https://insights.sbomify.com/CVE-2026-31890/): Inspektor Gadget: Tracing Denial of Service via Event Flooding (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24905 and fix it if it is affected.

What it is: CVE-2026-24905 is a medium-severity command injection vulnerability in inspektor-gadget, published on 29 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24905 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/inspektor-gadget/inspektor-gadget (Go): affected all versions; fixed in 0.51.1
- github.com/inspektor-gadget/inspektor-gadget (Go): affected all versions; fixed in 0.51.1
- github.com/inspektor-gadget/inspektor-gadget (Go): affected all versions; fixed in 0.51.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24905/ (Markdown: https://insights.sbomify.com/CVE-2026-24905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24905
- OSV: https://osv.dev/vulnerability/CVE-2026-24905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24905/
Summaries are generated and may contain mistakes; the official description above is the record.
