# CVE-2026-25041: Budibase has a Command Injection in PostgreSQL Dump Command

> Attackers can execute arbitrary commands via unsanitized PostgreSQL connection parameters in Budibase, requiring an upgrade to secure the platform.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-726g-59wr-cj4c

## What is CVE-2026-25041?

CVE-2026-25041 is a high-severity command injection vulnerability in budibase, published on 9 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Budibase is a low code platform for creating internal tools, workflows, and admin panels. In 3.23.22 and earlier, the PostgreSQL integration constructs shell commands using user-controlled configuration values (database name, host, password, etc.) without proper sanitization. The password and other connection parameters are directly interpolated into a shell command. This affects packages/server/src/integrations/postgres.ts.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-25041?

2 open source packages ship an affected version, including @budibase/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.23.32 |
| `@budibase/server` | npm | All versions | 3.23.32 |

Products: Budibase Budibase.

## How do I fix CVE-2026-25041?

Upgrade @budibase/server to 3.23.32 or later.

## Is CVE-2026-25041 being exploited?

There is no known exploitation of CVE-2026-25041 in the wild and no public exploit code.

## Other vulnerabilities in budibase

- [CVE-2026-54350](https://insights.sbomify.com/CVE-2026-54350/): Budibase: Anonymous NoSQL operator injection via published-app query templates (critical 10.0)
- [CVE-2026-27702](https://insights.sbomify.com/CVE-2026-27702/): Budibase Vulnerable to Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud) (critical 9.9)
- [CVE-2026-54352](https://insights.sbomify.com/CVE-2026-54352/): Budibase: Arbitrary file read by workspace-builder via PWA-zip symlink upload (critical 9.6)
- [CVE-2026-31818](https://insights.sbomify.com/CVE-2026-31818/): Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist (critical 9.6)
- [CVE-2026-30240](https://insights.sbomify.com/CVE-2026-30240/): Budibase PWA ZIP Upload Path Traversal Allows Reading Arbitrary Server Files Including All Environment Secrets (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25041 and fix it if it is affected.

What it is: CVE-2026-25041 is a high-severity command injection vulnerability in budibase, published on 9 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25041 in the wild and no public exploit code.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.23.32
- @budibase/server (npm): affected all versions; fixed in 3.23.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25041/ (Markdown: https://insights.sbomify.com/CVE-2026-25041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25041
- OSV: https://osv.dev/vulnerability/CVE-2026-25041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25041/
Summaries are generated and may contain mistakes; the official description above is the record.
