# CVE-2026-25046: [Kimi VS Code] Command Injection in publish scripts vsix-publish.js and ovsx-publish.js


- **Severity:** Low 2.9 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Jan 2026
- **Updated:** 2 Feb 2026

## What is CVE-2026-25046?

CVE-2026-25046 is a low-severity vulnerability in MoonshotAI kimi-agent-sdk, published on 29 Jan 2026. 

### Official description

Kimi Agent SDK is a set of libraries that expose the Kimi Code (Kimi CLI) agent runtime in applications. The vsix-publish.js and ovsx-publish.js scripts pass filenames to execSync() as shell command strings. Prior to version 0.1.6, filenames containing shell metacharacters like $(cmd) could execute arbitrary commands. Note: This vulnerability exists only in the repository's development scripts. The published VSCode extension does not include these files and end users are not affected. This is fixed in version 0.1.6 by replacing execSync with execFileSync using array arguments. As a workaround, ensure .vsix files in the project directory have safe filenames before running publish scripts.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-25046?


## How do I fix CVE-2026-25046?

No fix has been published for CVE-2026-25046 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25046 being exploited?

There is no known exploitation of CVE-2026-25046 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25046 and fix it if it is affected.

What it is: CVE-2026-25046 is a low-severity vulnerability in MoonshotAI kimi-agent-sdk, published on 29 Jan 2026. 
Exploitation: There is no known exploitation of CVE-2026-25046 in the wild and no public exploit code.

Affected product: MoonshotAI kimi-agent-sdk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25046/ (Markdown: https://insights.sbomify.com/CVE-2026-25046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25046
- OSV: https://osv.dev/vulnerability/CVE-2026-25046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25046/
Summaries are generated and may contain mistakes; the official description above is the record.
