{"answers":{"affected":"3 open source packages ship an affected version, including xgrammar. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-25048 in the wild and no public exploit code.","fix":"Upgrade xgrammar to 0.1.32 or later.","what":"CVE-2026-25048 is a high-severity denial of service vulnerability in mlc-ai xgrammar, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-25048 and fix it if it is affected.\n\nWhat it is: CVE-2026-25048 is a high-severity denial of service vulnerability in mlc-ai xgrammar, published on 5 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-25048 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- xgrammar (PyPI): affected all versions; fixed in 0.1.32\n- xgrammar (PyPI): affected all versions; fixed in 0.1.32\n- xgrammar (PyPI): affected all versions; fixed in 0.1.32\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25048/ (Markdown: https://insights.sbomify.com/CVE-2026-25048/index.md)","id":"CVE-2026-25048","markdown":"https://insights.sbomify.com/CVE-2026-25048/index.md","name":"CVE-2026-25048","record":{"aliases":["GHSA-7rgv-gqhr-fxg3","PYSEC-2026-2322"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python structured generation library","requires_auth":"none","summary":"Attackers can cause a segmentation fault and denial of service in xgrammar by providing multi-layer nested syntax inputs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"xgrammar","vendor":"mlc-ai"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"xgrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.32, the multi-level nested syntax caused a segmentation fault (core dumped). This issue has been patched in version 0.1.32.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"xgrammar: Multi-layer nesting causes DoS","id":"CVE-2026-25048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"n8n Has an Expression Escape Vulnerability Leading to RCE","id":"CVE-2026-25049"},"packages":[{"ecosystem":"PyPI","fixed":["0.1.32"],"introduced":["0"],"last_affected":[],"package":"xgrammar","purl":null,"source":"GHSA-7rgv-gqhr-fxg3"},{"ecosystem":"PyPI","fixed":["0.1.32"],"introduced":["0"],"last_affected":[],"package":"xgrammar","purl":"pkg:pypi/xgrammar","source":"GHSA-7rgv-gqhr-fxg3"},{"ecosystem":"PyPI","fixed":["0.1.32"],"introduced":["0"],"last_affected":[],"package":"xgrammar","purl":"pkg:pypi/xgrammar","source":"PYSEC-2026-2322"}],"prev":{"headline":"deepHas vulnerable to Prototype Pollution via constructor.prototype","id":"CVE-2026-25047"},"products":["xgrammar"],"published":"2026-03-05","related":[{"cvss_score":7.7,"headline":"XGrammar affected by Denial of Service by infinite recursion grammars","id":"CVE-2025-57809","kev_date_added":null,"published":"2025-08-25"},{"cvss_score":6.9,"headline":"xgrammar vulnerable to denial of service by huge enum grammar","id":"CVE-2025-58446","kev_date_added":null,"published":"2025-09-06"},{"cvss_score":6.5,"headline":"Denial of Service by abusing xgrammar unbounded cache in memory","id":"CVE-2025-32381","kev_date_added":null,"published":"2025-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-21","vendors":["mlc-ai"]},"summary":"Attackers can cause a segmentation fault and denial of service in xgrammar by providing multi-layer nested syntax inputs.","url":"https://insights.sbomify.com/CVE-2026-25048/"}