CVE-2026-25049 n8n Has an Expression Escape Vulnerability Leading to RCE
Authenticated users can execute arbitrary system commands on the host via crafted expressions in workflow parameters.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25049?
CVE-2026-25049 is a critical code injection vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.17 and 2.5.2, an authenticated user with permission to create or modify workflows could abuse crafted expressions in workflow parameters to trigger unintended system command execution on the host running n8n. This issue has been patched in versions 1.123.17 and 2.5.2.
Weakness: CWE-913
Which versions are affected by CVE-2026-25049?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.17 |
n8n npm | All versions | 1.123.17 |
n8n npm | From 2.0.0 | 2.5.2 |
n8n npm | From 2.0.0 | 2.5.2 |
Products include N8n N8n.
How do I fix CVE-2026-25049?
Upgrade n8n to a fixed version for your release line: 1.123.17 or 2.5.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-25049 being exploited?
There is no known exploitation of CVE-2026-25049 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-6cqr-8cfr-67f8.