# CVE-2026-25051: n8n Improper CSP Enforcement in Webhook Responses May Allow Stored XSS

> Authenticated users can inject malicious scripts into webhook responses due to improper CSP enforcement, leading to session hijacking and account takeover for other users.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-825q-w924-xhgx

## What is CVE-2026-25051?

CVE-2026-25051 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

n8n is an open source workflow automation platform. Prior to version 1.123.2, a Cross-Site Scripting (XSS) vulnerability has been identified in the handling of webhook responses and related HTTP endpoints. Under certain conditions, the Content Security Policy (CSP) sandbox protection intended to isolate HTML responses may not be applied correctly. An authenticated user with permission to create or modify workflows could abuse this to execute malicious scripts with same-origin privileges when other users interact with the crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in version 1.123.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25051?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.122.5 |
| `n8n` | npm | All versions | 1.122.5 |
| `n8n` | npm | From 1.123.0 | 1.123.2 |
| `n8n` | npm | From 1.123.0 | 1.123.2 |

Products: N8n N8n.

## How do I fix CVE-2026-25051?

Upgrade n8n to a fixed version for your release line: 1.122.5 or 1.123.2.

## Is CVE-2026-25051 being exploited?

There is no known exploitation of CVE-2026-25051 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25051 and fix it if it is affected.

What it is: CVE-2026-25051 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25051 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.122.5
- n8n (npm): affected all versions; fixed in 1.122.5
- n8n (npm): affected from 1.123.0; fixed in 1.123.2
- n8n (npm): affected from 1.123.0; fixed in 1.123.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25051/ (Markdown: https://insights.sbomify.com/CVE-2026-25051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25051
- OSV: https://osv.dev/vulnerability/CVE-2026-25051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25051/
Summaries are generated and may contain mistakes; the official description above is the record.
