CVE-2026-25053 n8n is Vulnerable to OS Command Injection in Git Node
Authenticated users with workflow permissions can execute arbitrary system commands or read files on the n8n host via the Git node.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25053?
CVE-2026-25053 is a critical command injection vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.10 and 2.5.0, vulnerabilities in the Git node allowed authenticated users with permission to create or modify workflows to execute arbitrary system commands or read arbitrary files on the n8n host. This issue has been patched in versions 1.123.10 and 2.5.0.
Weakness: CWE-78
Which versions are affected by CVE-2026-25053?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.10 |
n8n npm | All versions | 1.123.10 |
n8n npm | From 2.0.0 | 2.5.0 |
n8n npm | From 2.0.0 | 2.5.0 |
Products include N8n N8n.
How do I fix CVE-2026-25053?
Upgrade n8n to a fixed version for your release line: 1.123.10 or 2.5.0.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-25053 being exploited?
There is no known exploitation of CVE-2026-25053 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-9g95-qf3f-ggrw.