CVE-2026-25054 n8n is Vulnerable to Stored Cross-Site Scripting via Markdown Rendering in Workflow UI
Authenticated users can inject malicious scripts via markdown in workflow UI, leading to session hijacking and account takeover for other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-25054?
CVE-2026-25054 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.9 and 2.2.1, a Cross-Site Scripting (XSS) vulnerability existed in a markdown rendering component used in n8n's interface, including workflow sticky notes and other areas that support markdown content. An authenticated user with permission to create or modify workflows could abuse this to execute scripts with same-origin privileges when other users interact with a maliciously crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in versions 1.123.9 and 2.2.1.
Which versions are affected by CVE-2026-25054?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.9 |
n8n npm | All versions | 1.123.9 |
n8n npm | From 2.0.0 | 2.2.1 |
n8n npm | From 2.0.0 | 2.2.1 |
Products include N8n N8n.
How do I fix CVE-2026-25054?
Upgrade n8n to a fixed version for your release line: 1.123.9 or 2.2.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-25054 being exploited?
There is no known exploitation of CVE-2026-25054 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-qpq4-pw7f-pp8w.