# CVE-2026-25054: n8n is Vulnerable to Stored Cross-Site Scripting via Markdown Rendering in Workflow UI

> Authenticated users can inject malicious scripts via markdown in workflow UI, leading to session hijacking and account takeover for other users.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-qpq4-pw7f-pp8w

## What is CVE-2026-25054?

CVE-2026-25054 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

n8n is an open source workflow automation platform. Prior to versions 1.123.9 and 2.2.1, a Cross-Site Scripting (XSS) vulnerability existed in a markdown rendering component used in n8n's interface, including workflow sticky notes and other areas that support markdown content. An authenticated user with permission to create or modify workflows could abuse this to execute scripts with same-origin privileges when other users interact with a maliciously crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in versions 1.123.9 and 2.2.1.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25054?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.9 |
| `n8n` | npm | All versions | 1.123.9 |
| `n8n` | npm | From 2.0.0 | 2.2.1 |
| `n8n` | npm | From 2.0.0 | 2.2.1 |

Products: N8n N8n.

## How do I fix CVE-2026-25054?

Upgrade n8n to a fixed version for your release line: 1.123.9 or 2.2.1.

## Is CVE-2026-25054 being exploited?

There is no known exploitation of CVE-2026-25054 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25054 and fix it if it is affected.

What it is: CVE-2026-25054 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 4 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25054 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.9
- n8n (npm): affected all versions; fixed in 1.123.9
- n8n (npm): affected from 2.0.0; fixed in 2.2.1
- n8n (npm): affected from 2.0.0; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25054/ (Markdown: https://insights.sbomify.com/CVE-2026-25054/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25054
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25054
- OSV: https://osv.dev/vulnerability/CVE-2026-25054

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25054/
Summaries are generated and may contain mistakes; the official description above is the record.
