# CVE-2026-25060: OpenList Insecure TLS Default Configuration

> OpenList frontend disables TLS certificate verification by default, allowing Man-in-the-Middle attackers to intercept and manipulate storage communications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-wf93-3ghh-h389, GO-2026-4397

## What is CVE-2026-25060?

CVE-2026-25060 is a high-severity vulnerability in OpenListTeam OpenList, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenList Frontend is a UI component for OpenList. Prior to 4.1.10, certificate verification is disabled by default for all storage driver communications. The TlsInsecureSkipVerify setting is default to true in the DefaultConfig() function in internal/conf/config.go. This vulnerability enables Man-in-the-Middle (MitM) attacks by disabling TLS certificate verification, allowing attackers to intercept and manipulate all storage communications. Attackers can exploit this through network-level attacks like ARP spoofing, rogue Wi-Fi access points, or compromised internal network equipment to redirect traffic to malicious endpoints. Since certificate validation is skipped, the system will unknowingly establish encrypted connections with attacker-controlled servers, enabling full decryption, data theft, and manipulation of all storage operations without triggering any security warnings. This vulnerability is fixed in 4.1.10.

Weakness: CWE-599 (Missing Validation of OpenSSL Certificate)

## Which versions are affected by CVE-2026-25060?

5 open source packages ship an affected version, including github.com/OpenListTeam/OpenList/v4, github.com/OpenListTeam/OpenList and github.com/OpenListTeam/OpenList/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/OpenListTeam/OpenList/v4` | Go | All versions | 4.1.10 |
| `github.com/OpenListTeam/OpenList/v4` | Go | All versions | 4.1.10 |
| `github.com/OpenListTeam/OpenList/v4` | Go | All versions | 4.1.10 |
| `github.com/OpenListTeam/OpenList` | Go | All versions | None |
| `github.com/OpenListTeam/OpenList/v3` | Go | All versions | None |

Products: Oplist Openlist.

## How do I fix CVE-2026-25060?

Upgrade github.com/OpenListTeam/OpenList/v4 to 4.1.10 or later.

## Is CVE-2026-25060 being exploited?

There is no known exploitation of CVE-2026-25060 in the wild and no public exploit code.

## Other vulnerabilities in OpenListTeam OpenList

- [CVE-2026-25059](https://insights.sbomify.com/CVE-2026-25059/): OpenList affected by Path Traversal in file copy and remove handlers (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25060 and fix it if it is affected.

What it is: CVE-2026-25060 is a high-severity vulnerability in OpenListTeam OpenList, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25060 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/OpenListTeam/OpenList/v4 (Go): affected all versions; fixed in 4.1.10
- github.com/OpenListTeam/OpenList/v4 (Go): affected all versions; fixed in 4.1.10
- github.com/OpenListTeam/OpenList/v4 (Go): affected all versions; fixed in 4.1.10
- github.com/OpenListTeam/OpenList (Go): affected all versions; no fix listed
- github.com/OpenListTeam/OpenList/v3 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25060/ (Markdown: https://insights.sbomify.com/CVE-2026-25060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25060
- OSV: https://osv.dev/vulnerability/CVE-2026-25060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25060/
Summaries are generated and may contain mistakes; the official description above is the record.
