CVE-2026-25087 Apache Arrow: Potential use-after-free when reading IPC file with pre-buffering
Attackers can cause crashes or potential code execution in Apache Arrow C++ by providing malicious IPC files when pre-buffering is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25087?
CVE-2026-25087 is a high-severity use after free vulnerability in Apache Arrow, published on 17 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Use After Free vulnerability in Apache Arrow C++.
This issue affects Apache Arrow C++ from 15.0.0 through 23.0.0. It can be triggered when reading an Arrow IPC file (but not an IPC stream) with pre-buffering enabled, if the IPC file contains data with variadic buffers (such as Binary View and String View data). Depending on the number of variadic buffers in a record batch column and on the temporal sequence of multi-threaded IO, a write to a dangling pointer could occur. The value (a `std::shared_ptr<Buffer>` object) that is written to the dangling pointer is not under direct control of the attacker.
Pre-buffering is disabled by default but can be enabled using a specific C++ API call (`RecordBatchFileReader::PreBufferMetadata`). The functionality is not exposed in language bindings (Python, Ruby, C GLib), so these bindings are not vulnerable.
The most likely consequence of this issue would be random crashes or memory corruption when reading specific kinds of IPC files. If the application allows ingesting IPC files from untrusted sources, this could plausibly be exploited for denial of service. Inducing more targeted kinds of misbehavior (such as confidential data extraction from the running process) depends on memory allocation and multi-threaded IO temporal patterns that are unlikely to be easily controlled by an attacker.
Advice for users of Arrow C++:
1. check whether you enable pre-buffering on the IPC file reader (using `RecordBatchFileReader::PreBufferMetadata`)
2. if so, either disable pre-buffering (which may have adverse performance consequences), or switch to Arrow 23.0.1 which is not vulnerable
Weakness: CWE-416
Which versions are affected by CVE-2026-25087?
3 open source packages ship an affected version, including pyarrow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pyarrow PyPI | From 15.0.0 | 23.0.1 |
pyarrow PyPI | From 15.0.0 | 23.0.1 |
pyarrow PyPI | From 15.0.0 | 23.0.1 |
Products include Apache Arrow.
How do I fix CVE-2026-25087?
Upgrade pyarrow to 23.0.1 or later.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2026-25087 being exploited?
There is no known exploitation of CVE-2026-25087 in the wild and no public exploit code.
Other vulnerabilities in Apache Arrow
- CVE-2024-52338 Apache Arrow R package: Arbitrary code execution when loading a malicious data file
- CVE-2024-41178 Apache Arrow Rust Object Store: AWS WebIdentityToken exposure in log files
- CVE-2019-12408 Missing Initialization of Resource in Apache Arrow
- CVE-2019-12410 Missing Initialization of Resource in Apache Arrow
Sources
Also known as AZL-78129, DEBIAN-CVE-2026-25087, ECHO-9cfa-d930-6696, GHSA-rgxp-2hwp-jwgg, JLSEC-2026-805, MINI-3x5g-6g6j-jjc5 and 6 more.