# CVE-2026-25087: Apache Arrow: Potential use-after-free when reading IPC file with pre-buffering

> Attackers can cause crashes or potential code execution in Apache Arrow C++ by providing malicious IPC files when pre-buffering is enabled.

- **Severity:** High 7.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** AZL-78129, DEBIAN-CVE-2026-25087, ECHO-9cfa-d930-6696, GHSA-rgxp-2hwp-jwgg, JLSEC-2026-805, MINI-3x5g-6g6j-jjc5, MINI-966c-36wj-v9xr, MINI-cmwg-65v3-h4gx, MINI-q6fr-m6hv-5g8m, MINI-q9cx-cc7h-w885, PYSEC-2026-113, ROOT-APP-PYPI-CVE-2026-25087

## What is CVE-2026-25087?

CVE-2026-25087 is a high-severity use after free vulnerability in Apache Arrow, published on 17 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Use After Free vulnerability in Apache Arrow C++.

This issue affects Apache Arrow C++ from 15.0.0 through 23.0.0. It can be triggered when reading an Arrow IPC file (but not an IPC stream) with pre-buffering enabled, if the IPC file contains data with variadic buffers (such as Binary View and String View data). Depending on the number of variadic buffers in a record batch column and on the temporal sequence of multi-threaded IO, a write to a dangling pointer could occur. The value (a `std::shared_ptr<Buffer>` object) that is written to the dangling pointer is not under direct control of the attacker.

Pre-buffering is disabled by default but can be enabled using a specific C++ API call (`RecordBatchFileReader::PreBufferMetadata`). The functionality is not exposed in language bindings (Python, Ruby, C GLib), so these bindings are not vulnerable.

The most likely consequence of this issue would be random crashes or memory corruption when reading specific kinds of IPC files. If the application allows ingesting IPC files from untrusted sources, this could plausibly be exploited for denial of service. Inducing more targeted kinds of misbehavior (such as confidential data extraction from the running process) depends on memory allocation and multi-threaded IO temporal patterns that are unlikely to be easily controlled by an attacker.

Advice for users of Arrow C++:

1. check whether you enable pre-buffering on the IPC file reader (using `RecordBatchFileReader::PreBufferMetadata`)

2. if so, either disable pre-buffering (which may have adverse performance consequences), or switch to Arrow 23.0.1 which is not vulnerable

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-25087?

3 open source packages ship an affected version, including pyarrow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyarrow` | PyPI | From 15.0.0 | 23.0.1 |
| `pyarrow` | PyPI | From 15.0.0 | 23.0.1 |
| `pyarrow` | PyPI | From 15.0.0 | 23.0.1 |

Products: Apache Arrow.

## How do I fix CVE-2026-25087?

Upgrade pyarrow to 23.0.1 or later.

## Is CVE-2026-25087 being exploited?

There is no known exploitation of CVE-2026-25087 in the wild and no public exploit code.

## Other vulnerabilities in Apache Arrow

- [CVE-2024-52338](https://insights.sbomify.com/CVE-2024-52338/): Apache Arrow R package: Arbitrary code execution when loading a malicious data file (critical 9.8)
- [CVE-2024-41178](https://insights.sbomify.com/CVE-2024-41178/): Apache Arrow Rust Object Store: AWS WebIdentityToken exposure in log files (high 7.5)
- [CVE-2019-12408](https://insights.sbomify.com/CVE-2019-12408/): Missing Initialization of Resource in Apache Arrow (high 7.5)
- [CVE-2019-12410](https://insights.sbomify.com/CVE-2019-12410/): Missing Initialization of Resource in Apache Arrow (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25087 and fix it if it is affected.

What it is: CVE-2026-25087 is a high-severity use after free vulnerability in Apache Arrow, published on 17 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25087 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyarrow (PyPI): affected from 15.0.0; fixed in 23.0.1
- pyarrow (PyPI): affected from 15.0.0; fixed in 23.0.1
- pyarrow (PyPI): affected from 15.0.0; fixed in 23.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25087/ (Markdown: https://insights.sbomify.com/CVE-2026-25087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25087
- OSV: https://osv.dev/vulnerability/CVE-2026-25087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25087/
Summaries are generated and may contain mistakes; the official description above is the record.
