# CVE-2026-25101: Session Fixation in Bludit


- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-fjj5-fj78-h28j

## What is CVE-2026-25101?

CVE-2026-25101 is a medium-severity vulnerability in Bludit, published on 27 Mar 2026. 

### Official description

Bludit allows user's session identifier to be set before authentication. The value of this session ID stays the same after authentication. This behavior enables an attacker to fix a session ID
for a victim and later hijack the authenticated session.

This issue was fixed in version 3.17.2.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-25101?

It affects 1 product.


Products: Bludit Bludit.

## How do I fix CVE-2026-25101?

No fix has been published for CVE-2026-25101 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25101 being exploited?

There is no known exploitation of CVE-2026-25101 in the wild and no public exploit code.

## Other vulnerabilities in Bludit

- [CVE-2020-18879](https://insights.sbomify.com/CVE-2020-18879/): File upload in n/a (critical 9.8)
- [CVE-2020-20495](https://insights.sbomify.com/CVE-2020-20495/): Path traversal in n/a (critical 9.1)
- [CVE-2020-18190](https://insights.sbomify.com/CVE-2020-18190/): Path traversal in n/a (critical 9.1)
- [CVE-2024-24550](https://insights.sbomify.com/CVE-2024-24550/): Bludit - Remote Code Execution (RCE) through File API (high 8.9)
- [CVE-2024-24551](https://insights.sbomify.com/CVE-2024-24551/): Bludit - Remote Code Execution (RCE) through Image API (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25101 and fix it if it is affected.

What it is: CVE-2026-25101 is a medium-severity vulnerability in Bludit, published on 27 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2026-25101 in the wild and no public exploit code.

Affected product: Bludit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25101/ (Markdown: https://insights.sbomify.com/CVE-2026-25101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25101
- OSV: https://osv.dev/vulnerability/CVE-2026-25101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25101/
Summaries are generated and may contain mistakes; the official description above is the record.
