# CVE-2026-25119: Gogs: Authentication Bypass via Unvalidated Reverse Proxy Headers

> Attackers can bypass authentication and impersonate users by forging headers when reverse proxy authentication is enabled.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-w6j9-vw59-27wv, GO-2026-5695

## What is CVE-2026-25119?

CVE-2026-25119 is a high-severity authentication bypass vulnerability in gogs, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. Prior to 0.14.3, when ENABLE_REVERSE_PROXY_AUTHENTICATION is enabled, Gogs accepts the configured authentication header (default: X-WEBAUTH-USER) directly from client requests without validating that the request originated from a trusted reverse proxy. Any remote attacker who can reach the Gogs service can forge this header to impersonate any user or trigger automatic account creation, completely bypassing authentication. This vulnerability is fixed in 0.14.3.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-25119?

3 open source packages ship an affected version, including gogs.io/gogs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |
| `gogs.io/gogs` | Go | All versions | 0.14.3 |

## How do I fix CVE-2026-25119?

Upgrade gogs.io/gogs to 0.14.3 or later.

## Is CVE-2026-25119 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25119 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25119 and fix it if it is affected.

What it is: CVE-2026-25119 is a high-severity authentication bypass vulnerability in gogs, published on 24 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25119 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25119/ (Markdown: https://insights.sbomify.com/CVE-2026-25119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25119
- OSV: https://osv.dev/vulnerability/CVE-2026-25119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25119/
Summaries are generated and may contain mistakes; the official description above is the record.
