CVE-2026-25125 October CMS: Environment Variable Exfiltration via INI Parser Interpolation
Attackers with Editor access can exfiltrate sensitive environment variables via INI parser interpolation, potentially leading to credential theft and further compromise.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25125?
CVE-2026-25125 is a medium-severity vulnerability in Octobercms October, published on 14 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a server-side information disclosure vulnerability in the INI settings parser. Because PHP's parse_ini_string() function supports ${} syntax for environment variable interpolation, attackers with Editor access could inject patterns such as ${APP_KEY} or ${DB_PASSWORD} into CMS page settings fields, causing sensitive environment variables to be resolved, stored in the template, and returned to the attacker when the page was reopened. This could enable exfiltration of credentials and secrets (database passwords, AWS keys, application keys), potentially leading to further attacks such as database access or cookie forgery. The vulnerability is only relevant when cms.safe_mode is enabled, as direct PHP injection is already possible otherwise. This issue has been fixed in versions 3.7.14 and 4.1.10. If users are unable to immediately upgrade, they can workaround this issue by restricting Editor tool access to fully trusted administrators only, and ensuring database and cloud service credentials are not accessible from the web server's network.
Which versions are affected by CVE-2026-25125?
4 open source packages ship an affected version, including october/rain. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
october/rain Packagist | All versions | 3.7.14 |
october/rain Packagist | All versions | 3.7.14 |
october/rain Packagist | From 4.0.0 | 4.1.10 |
october/rain Packagist | From 4.0.0 | 4.1.10 |
Products include Octobercms October.
How do I fix CVE-2026-25125?
Upgrade october/rain to a fixed version for your release line: 3.7.14 or 4.1.10.
Is CVE-2026-25125 being exploited?
There is no known exploitation of CVE-2026-25125 in the wild and no public exploit code.
Other vulnerabilities in Octobercms October
Sources
Also known as GHSA-g6v3-wv4j-x9hg.