# CVE-2026-25125: October CMS: Environment Variable Exfiltration via INI Parser Interpolation

> Attackers with Editor access can exfiltrate sensitive environment variables via INI parser interpolation, potentially leading to credential theft and further compromise.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-g6v3-wv4j-x9hg

## What is CVE-2026-25125?

CVE-2026-25125 is a medium-severity vulnerability in Octobercms October, published on 14 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a server-side information disclosure vulnerability in the INI settings parser. Because PHP's parse_ini_string() function supports ${} syntax for environment variable interpolation, attackers with Editor access could inject patterns such as ${APP_KEY} or ${DB_PASSWORD} into CMS page settings fields, causing sensitive environment variables to be resolved, stored in the template, and returned to the attacker when the page was reopened. This could enable exfiltration of credentials and secrets (database passwords, AWS keys, application keys), potentially leading to further attacks such as database access or cookie forgery. The vulnerability is only relevant when cms.safe_mode is enabled, as direct PHP injection is already possible otherwise. This issue has been fixed in versions 3.7.14 and 4.1.10. If users are unable to immediately upgrade, they can workaround this issue by restricting Editor tool access to fully trusted administrators only, and ensuring database and cloud service credentials are not accessible from the web server's network.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-25125?

4 open source packages ship an affected version, including october/rain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/rain` | Packagist | All versions | 3.7.14 |
| `october/rain` | Packagist | All versions | 3.7.14 |
| `october/rain` | Packagist | From 4.0.0 | 4.1.10 |
| `october/rain` | Packagist | From 4.0.0 | 4.1.10 |

Products: Octobercms October.

## How do I fix CVE-2026-25125?

Upgrade october/rain to a fixed version for your release line: 3.7.14 or 4.1.10.

## Is CVE-2026-25125 being exploited?

There is no known exploitation of CVE-2026-25125 in the wild and no public exploit code.

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25125 and fix it if it is affected.

What it is: CVE-2026-25125 is a medium-severity vulnerability in Octobercms October, published on 14 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25125 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/rain (Packagist): affected all versions; fixed in 3.7.14
- october/rain (Packagist): affected all versions; fixed in 3.7.14
- october/rain (Packagist): affected from 4.0.0; fixed in 4.1.10
- october/rain (Packagist): affected from 4.0.0; fixed in 4.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25125/ (Markdown: https://insights.sbomify.com/CVE-2026-25125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25125
- OSV: https://osv.dev/vulnerability/CVE-2026-25125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25125/
Summaries are generated and may contain mistakes; the official description above is the record.
