{"answers":{"affected":"2 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25128 exists.","fix":"Upgrade fast-xml-parser to 5.3.4 or later.","what":"CVE-2026-25128 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 30 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-25128 and fix it if it is affected.\n\nWhat it is: CVE-2026-25128 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 30 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25128 exists.\n\nAffected packages and fixed versions:\n- fast-xml-parser (npm): affected from 5.0.9; fixed in 5.3.4\n- fast-xml-parser (npm): affected from 5.0.9; fixed in 5.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25128/ (Markdown: https://insights.sbomify.com/CVE-2026-25128/index.md)","id":"CVE-2026-25128","markdown":"https://insights.sbomify.com/CVE-2026-25128/index.md","name":"CVE-2026-25128","record":{"aliases":["CLEANSTART-2026-HA50090","CLEANSTART-2026-XI72782","CLSA-2026-1774398086","CLSA-2026-1784856386","GHSA-37qj-frw5-hhjh","MINI-3q7m-3687-m58w","MINI-43x7-cxxf-5jp7","MINI-7xph-h7j8-vhj2","MINI-9fx9-64xr-59mm","MINI-g7gx-qq42-r9pq","MINI-h2mg-cxxr-vc9v","MINI-h533-gg46-j7rh","MINI-p2j3-rvwr-6c79","MINI-qf27-7fpf-gpf4","MINI-wm6j-gfjc-hqj5","MINI-xf84-79fm-2mc3","ROOT-APP-NPM-CVE-2026-25128","UBUNTU-CVE-2026-25128"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript XML parser","requires_auth":"none","summary":"An attacker can crash applications using fast-xml-parser by sending XML with out-of-range numeric entities, causing an uncaught RangeError exception.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fast-xml-parser","vendor":"naturalintelligence"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. In versions 5.0.9 through 5.3.3, a RangeError vulnerability exists in the numeric entity processing of fast-xml-parser when parsing XML with out-of-range entity code points (e.g., `\u0026#9999999;` or `\u0026#xFFFFFF;`). This causes the parser to throw an uncaught exception, crashing any application that processes untrusted XML input. Version 5.3.4 fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"fast-xml-parser has RangeError DoS Numeric Entities Bug","id":"CVE-2026-25128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"PsySH has Local Privilege Escalation via CWD .psysh.php auto-load","id":"CVE-2026-25129"},"packages":[{"ecosystem":"npm","fixed":["5.3.4"],"introduced":["5.0.9"],"last_affected":[],"package":"fast-xml-parser","purl":null,"source":"GHSA-37qj-frw5-hhjh"},{"ecosystem":"npm","fixed":["5.3.4"],"introduced":["5.0.9"],"last_affected":[],"package":"fast-xml-parser","purl":"pkg:npm/fast-xml-parser","source":"GHSA-37qj-frw5-hhjh"}],"prev":{"headline":"OpenEMR has Broken Access Control on Care Coordination Module","id":"CVE-2026-25127"},"products":["fast-xml-parser"],"published":"2026-01-30","related":[{"cvss_score":9.3,"headline":"fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names","id":"CVE-2026-25896","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":7.5,"headline":"fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)","id":"CVE-2026-33036","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":7.5,"headline":"fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit)","id":"CVE-2026-26278","kev_date_added":null,"published":"2026-02-19"},{"cvss_score":7.5,"headline":"ReDOS at currency parsing fast-xml-parser","id":"CVE-2024-41818","kev_date_added":null,"published":"2024-07-29"},{"cvss_score":7.5,"headline":"Regex Injection via Doctype Entities","id":"CVE-2023-34104","kev_date_added":null,"published":"2023-06-06"},{"cvss_score":6.1,"headline":"fast-xml-parser XMLBuilder: XML Comment and CDATA Injection via Unescaped Delimiters","id":"CVE-2026-41650","kev_date_added":null,"published":"2026-05-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-11","vendors":["NaturalIntelligence"]},"summary":"An attacker can crash applications using fast-xml-parser by sending XML with out-of-range numeric entities, causing an uncaught RangeError exception.","url":"https://insights.sbomify.com/CVE-2026-25128/"}