# CVE-2026-25128: fast-xml-parser has RangeError DoS Numeric Entities Bug

> An attacker can crash applications using fast-xml-parser by sending XML with out-of-range numeric entities, causing an uncaught RangeError exception.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2026
- **Updated:** 11 Feb 2026
- **Also known as:** CLEANSTART-2026-HA50090, CLEANSTART-2026-XI72782, CLSA-2026-1774398086, CLSA-2026-1784856386, GHSA-37qj-frw5-hhjh, MINI-3q7m-3687-m58w, MINI-43x7-cxxf-5jp7, MINI-7xph-h7j8-vhj2, MINI-9fx9-64xr-59mm, MINI-g7gx-qq42-r9pq, MINI-h2mg-cxxr-vc9v, MINI-h533-gg46-j7rh, MINI-p2j3-rvwr-6c79, MINI-qf27-7fpf-gpf4, MINI-wm6j-gfjc-hqj5, MINI-xf84-79fm-2mc3, ROOT-APP-NPM-CVE-2026-25128, UBUNTU-CVE-2026-25128

## What is CVE-2026-25128?

CVE-2026-25128 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 30 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. In versions 5.0.9 through 5.3.3, a RangeError vulnerability exists in the numeric entity processing of fast-xml-parser when parsing XML with out-of-range entity code points (e.g., `&#9999999;` or `&#xFFFFFF;`). This causes the parser to throw an uncaught exception, crashing any application that processes untrusted XML input. Version 5.3.4 fixes the issue.

Weakness: CWE-248 (Uncaught Exception), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-25128?

2 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | From 5.0.9 | 5.3.4 |
| `fast-xml-parser` | npm | From 5.0.9 | 5.3.4 |

Products: Naturalintelligence Fast-Xml-Parser.

## How do I fix CVE-2026-25128?

Upgrade fast-xml-parser to 5.3.4 or later.

## Is CVE-2026-25128 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25128 exists.

## Other vulnerabilities in NaturalIntelligence fast-xml-parser

- [CVE-2026-25896](https://insights.sbomify.com/CVE-2026-25896/): fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names (critical 9.3)
- [CVE-2026-33036](https://insights.sbomify.com/CVE-2026-33036/): fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278) (high 7.5)
- [CVE-2026-26278](https://insights.sbomify.com/CVE-2026-26278/): fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit) (high 7.5)
- [CVE-2024-41818](https://insights.sbomify.com/CVE-2024-41818/): ReDOS at currency parsing fast-xml-parser (high 7.5)
- [CVE-2023-34104](https://insights.sbomify.com/CVE-2023-34104/): Regex Injection via Doctype Entities (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25128 and fix it if it is affected.

What it is: CVE-2026-25128 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 30 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25128 exists.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected from 5.0.9; fixed in 5.3.4
- fast-xml-parser (npm): affected from 5.0.9; fixed in 5.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25128/ (Markdown: https://insights.sbomify.com/CVE-2026-25128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25128
- OSV: https://osv.dev/vulnerability/CVE-2026-25128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25128/
Summaries are generated and may contain mistakes; the official description above is the record.
