CVE-2026-25129 PsySH has Local Privilege Escalation via CWD .psysh.php auto-load
Attacker can execute arbitrary code and escalate privileges by placing a malicious .psysh.php file in a directory used as the current working directory.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-25129?
CVE-2026-25129 is a medium-severity code injection vulnerability in bobthecow psysh, published on 30 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
PsySH is a runtime developer console, interactive debugger, and REPL for PHP. Prior to versions 0.11.23 and 0.12.19, PsySH automatically loads and executes a `.psysh.php` file from the Current Working Directory (CWD) on startup. If an attacker can write to a directory that a victim later uses as their CWD when launching PsySH, the attacker can trigger arbitrary code execution in the victim's context. When the victim runs PsySH with elevated privileges (e.g., root), this results in local privilege escalation. This is a CWD configuration poisoning issue leading to arbitrary code execution in the victim user’s context. If a privileged user (e.g., root, a CI runner, or an ops/debug account) launches PsySH with CWD set to an attacker-writable directory containing a malicious `.psysh.php`, the attacker can execute commands with that privileged user’s permissions, resulting in local privilege escalation. Downstream consumers that embed PsySH inherit this risk. For example, Laravel Tinker (`php artisan tinker`) uses PsySH. If a privileged user runs Tinker while their shell is in an attacker-writable directory, the `.psysh.php` auto-load behavior can be abused in the same way to execute attacker-controlled code under the victim’s privileges. Versions 0.11.23 and 0.12.19 patch the issue.
Weakness: CWE-427
Which versions are affected by CVE-2026-25129?
4 open source packages ship an affected version, including psy/psysh. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
psy/psysh Packagist | All versions | 0.11.23 |
psy/psysh Packagist | All versions | 0.11.23 |
psy/psysh Packagist | From 0.12.0 | 0.12.19 |
psy/psysh Packagist | From 0.12.0 | 0.12.19 |
Products include Psysh Psysh.
How do I fix CVE-2026-25129?
Upgrade psy/psysh to a fixed version for your release line: 0.11.23 or 0.12.19.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-25129 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25129 exists.
Sources
Also known as GHSA-4486-gxhx-5mg7.