{"answers":{"affected":"4 open source packages ship an affected version, including psy/psysh. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25129 exists.","fix":"Upgrade psy/psysh to a fixed version for your release line: 0.11.23 or 0.12.19.","what":"CVE-2026-25129 is a medium-severity code injection vulnerability in bobthecow psysh, published on 30 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-25129 and fix it if it is affected.\n\nWhat it is: CVE-2026-25129 is a medium-severity code injection vulnerability in bobthecow psysh, published on 30 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25129 exists.\n\nAffected packages and fixed versions:\n- psy/psysh (Packagist): affected all versions; fixed in 0.11.23\n- psy/psysh (Packagist): affected all versions; fixed in 0.11.23\n- psy/psysh (Packagist): affected from 0.12.0; fixed in 0.12.19\n- psy/psysh (Packagist): affected from 0.12.0; fixed in 0.12.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25129/ (Markdown: https://insights.sbomify.com/CVE-2026-25129/index.md)","id":"CVE-2026-25129","markdown":"https://insights.sbomify.com/CVE-2026-25129/index.md","name":"CVE-2026-25129","record":{"aliases":["GHSA-4486-gxhx-5mg7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP REPL library","requires_auth":"low_privilege","summary":"Attacker can execute arbitrary code and escalate privileges by placing a malicious .psysh.php file in a directory used as the current working directory.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"psysh","vendor":"psysh"}],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"}],"description":"PsySH is a runtime developer console, interactive debugger, and REPL for PHP. Prior to versions 0.11.23 and 0.12.19, PsySH automatically loads and executes a `.psysh.php` file from the Current Working Directory (CWD) on startup. If an attacker can write to a directory that a victim later uses as their CWD when launching PsySH, the attacker can trigger arbitrary code execution in the victim's context. When the victim runs PsySH with elevated privileges (e.g., root), this results in local privilege escalation. This is a CWD configuration poisoning issue leading to arbitrary code execution in the victim user’s context. If a privileged user (e.g., root, a CI runner, or an ops/debug account) launches PsySH with CWD set to an attacker-writable directory containing a malicious `.psysh.php`, the attacker can execute commands with that privileged user’s permissions, resulting in local privilege escalation. Downstream consumers that embed PsySH inherit this risk. For example, Laravel Tinker (`php artisan tinker`) uses PsySH. If a privileged user runs Tinker while their shell is in an attacker-writable directory, the `.psysh.php` auto-load behavior can be abused in the same way to execute attacker-controlled code under the victim’s privileges. Versions 0.11.23 and 0.12.19 patch the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PsySH has Local Privilege Escalation via CWD .psysh.php auto-load","id":"CVE-2026-25129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Cybersecurity AI vulnerable to command Injection through argument injection in find_file Agent tool","id":"CVE-2026-25130"},"packages":[{"ecosystem":"Packagist","fixed":["0.11.23"],"introduced":["0"],"last_affected":[],"package":"psy/psysh","purl":null,"source":"GHSA-4486-gxhx-5mg7"},{"ecosystem":"Packagist","fixed":["0.11.23"],"introduced":["0"],"last_affected":[],"package":"psy/psysh","purl":"pkg:composer/psy/psysh","source":"GHSA-4486-gxhx-5mg7"},{"ecosystem":"Packagist","fixed":["0.12.19"],"introduced":["0.12.0"],"last_affected":[],"package":"psy/psysh","purl":null,"source":"GHSA-4486-gxhx-5mg7"},{"ecosystem":"Packagist","fixed":["0.12.19"],"introduced":["0.12.0"],"last_affected":[],"package":"psy/psysh","purl":"pkg:composer/psy/psysh","source":"GHSA-4486-gxhx-5mg7"}],"prev":{"headline":"fast-xml-parser has RangeError DoS Numeric Entities Bug","id":"CVE-2026-25128"},"products":["psysh"],"published":"2026-01-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-02","vendors":["bobthecow"]},"summary":"Attacker can execute arbitrary code and escalate privileges by placing a malicious .psysh.php file in a directory used as the current working directory.","url":"https://insights.sbomify.com/CVE-2026-25129/"}