# CVE-2026-25129: PsySH has Local Privilege Escalation via CWD .psysh.php auto-load

> Attacker can execute arbitrary code and escalate privileges by placing a malicious .psysh.php file in a directory used as the current working directory.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jan 2026
- **Updated:** 2 Feb 2026
- **Also known as:** GHSA-4486-gxhx-5mg7

## What is CVE-2026-25129?

CVE-2026-25129 is a medium-severity code injection vulnerability in bobthecow psysh, published on 30 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PsySH is a runtime developer console, interactive debugger, and REPL for PHP. Prior to versions 0.11.23 and 0.12.19, PsySH automatically loads and executes a `.psysh.php` file from the Current Working Directory (CWD) on startup. If an attacker can write to a directory that a victim later uses as their CWD when launching PsySH, the attacker can trigger arbitrary code execution in the victim's context. When the victim runs PsySH with elevated privileges (e.g., root), this results in local privilege escalation. This is a CWD configuration poisoning issue leading to arbitrary code execution in the victim user’s context. If a privileged user (e.g., root, a CI runner, or an ops/debug account) launches PsySH with CWD set to an attacker-writable directory containing a malicious `.psysh.php`, the attacker can execute commands with that privileged user’s permissions, resulting in local privilege escalation. Downstream consumers that embed PsySH inherit this risk. For example, Laravel Tinker (`php artisan tinker`) uses PsySH. If a privileged user runs Tinker while their shell is in an attacker-writable directory, the `.psysh.php` auto-load behavior can be abused in the same way to execute attacker-controlled code under the victim’s privileges. Versions 0.11.23 and 0.12.19 patch the issue.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2026-25129?

4 open source packages ship an affected version, including psy/psysh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `psy/psysh` | Packagist | All versions | 0.11.23 |
| `psy/psysh` | Packagist | All versions | 0.11.23 |
| `psy/psysh` | Packagist | From 0.12.0 | 0.12.19 |
| `psy/psysh` | Packagist | From 0.12.0 | 0.12.19 |

Products: Psysh Psysh.

## How do I fix CVE-2026-25129?

Upgrade psy/psysh to a fixed version for your release line: 0.11.23 or 0.12.19.

## Is CVE-2026-25129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25129 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25129 and fix it if it is affected.

What it is: CVE-2026-25129 is a medium-severity code injection vulnerability in bobthecow psysh, published on 30 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25129 exists.

Affected packages and fixed versions:
- psy/psysh (Packagist): affected all versions; fixed in 0.11.23
- psy/psysh (Packagist): affected all versions; fixed in 0.11.23
- psy/psysh (Packagist): affected from 0.12.0; fixed in 0.12.19
- psy/psysh (Packagist): affected from 0.12.0; fixed in 0.12.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25129/ (Markdown: https://insights.sbomify.com/CVE-2026-25129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25129
- OSV: https://osv.dev/vulnerability/CVE-2026-25129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25129/
Summaries are generated and may contain mistakes; the official description above is the record.
