# CVE-2026-25133: October CMS has Stored XSS via SVG Filter Bypass

> Authenticated attackers can upload malicious SVG files to trigger stored XSS, potentially leading to privilege escalation when viewed by superusers.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-gcqv-f29m-67gr

## What is CVE-2026-25133?

CVE-2026-25133 is a medium-severity cross-site scripting vulnerability in Octobercms October, published on 14 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a stored cross-site scripting (XSS) vulnerability in the SVG sanitization logic. The regex pattern used to strip event handler attributes (such as onclick or onload) could be bypassed using a crafted payload that exploits how the pattern matches attribute boundaries, allowing malicious SVG files to be uploaded through the Media Manager with embedded JavaScript. Exploitation could lead to privilege escalation if a superuser views or embeds the malicious SVG, and requires authenticated backend access with media upload permissions. The SVG must be viewed or embedded in a page for the payload to trigger. This issue has been fixed in versions 3.7.14 and 4.1.10.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25133?

4 open source packages ship an affected version, including october/rain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/rain` | Packagist | All versions | 3.7.14 |
| `october/rain` | Packagist | All versions | 3.7.14 |
| `october/rain` | Packagist | From 4.0.0 | 4.1.10 |
| `october/rain` | Packagist | From 4.0.0 | 4.1.10 |

Products: Octobercms October.

## How do I fix CVE-2026-25133?

Upgrade october/rain to a fixed version for your release line: 3.7.14 or 4.1.10.

## Is CVE-2026-25133 being exploited?

There is no known exploitation of CVE-2026-25133 in the wild and no public exploit code.

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25133 and fix it if it is affected.

What it is: CVE-2026-25133 is a medium-severity cross-site scripting vulnerability in Octobercms October, published on 14 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25133 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/rain (Packagist): affected all versions; fixed in 3.7.14
- october/rain (Packagist): affected all versions; fixed in 3.7.14
- october/rain (Packagist): affected from 4.0.0; fixed in 4.1.10
- october/rain (Packagist): affected from 4.0.0; fixed in 4.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25133/ (Markdown: https://insights.sbomify.com/CVE-2026-25133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25133
- OSV: https://osv.dev/vulnerability/CVE-2026-25133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25133/
Summaries are generated and may contain mistakes; the official description above is the record.
