# CVE-2026-25136: Rucio WebUI has a Reflected Cross-site Scripting Vulnerability

> Attackers can steal user session tokens via reflected XSS in the WebUI error page, requiring an upgrade to secure the application.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-h79m-5jjm-jm4q, PYSEC-2026-3056

## What is CVE-2026-25136?

CVE-2026-25136 is a high-severity cross-site scripting vulnerability in rucio, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Rucio is a software framework that provides functionality to organize, manage, and access large volumes of scientific data using customizable policies. A reflected Cross-site Scripting vulnerability was located in versions prior to 35.8.3, 38.5.4, and 39.3.1 in the rendering of the ExceptionMessage of the WebUI 500 error which could allow attackers to steal login session tokens of users who navigate to a specially crafted URL. Versions 35.8.3, 38.5.4, and 39.3.1 fix the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-1004 (Sensitive Cookie Without 'HttpOnly' Flag)

## Which versions are affected by CVE-2026-25136?

7 open source packages ship an affected version, including rucio-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rucio-webui` | PyPI | All versions | 35.8.3, 38.5.4, 39.3.1 |
| `rucio-webui` | PyPI | All versions | 35.8.3 |
| `rucio-webui` | PyPI | All versions | 35.8.3 |
| `rucio-webui` | PyPI | From 36.0.0rc1 | 38.5.4 |
| `rucio-webui` | PyPI | From 36.0.0rc1 | 38.5.4 |
| `rucio-webui` | PyPI | From 39.0.0rc1 | 39.3.1 |
| `rucio-webui` | PyPI | From 39.0.0rc1 | 39.3.1 |

Products: Cern Rucio.

## How do I fix CVE-2026-25136?

Upgrade rucio-webui to a fixed version for your release line: 35.8.3, 38.5.4 or 39.3.1.

## Is CVE-2026-25136 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25136 exists.

## Other vulnerabilities in rucio

- [CVE-2026-29080](https://insights.sbomify.com/CVE-2026-29080/): Rucio SQL Injection in FilterEngine Oracle JSON Path via DID Search API (critical 9.4)
- [CVE-2026-29090](https://insights.sbomify.com/CVE-2026-29090/): Rucio SQL injection in postgres_meta DID search path compromises PostgreSQL metadata database (critical 9.0)
- [CVE-2026-25733](https://insights.sbomify.com/CVE-2026-25733/): Rucio WebUI Vulnerable to Stored Cross-site Scripting (XSS) through Custom Rule Function (high 7.3)
- [CVE-2026-25734](https://insights.sbomify.com/CVE-2026-25734/): Rucio WebUI has Stored Cross-site Scripting (XSS) in RSE Metadata (medium 6.1)
- [CVE-2026-25735](https://insights.sbomify.com/CVE-2026-25735/): Rucio WebUI has a Stored Cross-site Scripting (XSS) vulnerability its Identity Name (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25136 and fix it if it is affected.

What it is: CVE-2026-25136 is a high-severity cross-site scripting vulnerability in rucio, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25136 exists.

Affected packages and fixed versions:
- rucio-webui (PyPI): affected all versions; fixed in 35.8.3, 38.5.4, 39.3.1
- rucio-webui (PyPI): affected all versions; fixed in 35.8.3
- rucio-webui (PyPI): affected all versions; fixed in 35.8.3
- rucio-webui (PyPI): affected from 36.0.0rc1; fixed in 38.5.4
- rucio-webui (PyPI): affected from 36.0.0rc1; fixed in 38.5.4
- rucio-webui (PyPI): affected from 39.0.0rc1; fixed in 39.3.1
- rucio-webui (PyPI): affected from 39.0.0rc1; fixed in 39.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25136/ (Markdown: https://insights.sbomify.com/CVE-2026-25136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25136
- OSV: https://osv.dev/vulnerability/CVE-2026-25136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25136/
Summaries are generated and may contain mistakes; the official description above is the record.
