{"answers":{"affected":"1 open source package ship an affected version, including chainguard.dev/apko. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-25140 in the wild and no public exploit code.","fix":"Upgrade chainguard.dev/apko to 1.1.1 or later.","what":"CVE-2026-25140 is a high-severity denial of service vulnerability in chainguard-dev apko, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-25140 and fix it if it is affected.\n\nWhat it is: CVE-2026-25140 is a high-severity denial of service vulnerability in chainguard-dev apko, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-25140 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- chainguard.dev/apko (Go): affected from 0.14.8; fixed in 1.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25140/ (Markdown: https://insights.sbomify.com/CVE-2026-25140/index.md)","id":"CVE-2026-25140","markdown":"https://insights.sbomify.com/CVE-2026-25140/index.md","name":"CVE-2026-25140","record":{"aliases":["GHSA-f4w5-5xv9-85f6","GO-2026-4410","MINI-9q46-75mp-9653"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OCI container builder","requires_auth":"none","summary":"An attacker controlling an APK repository can cause resource exhaustion on the build host by serving highly compressed APK streams, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apko","vendor":"chainguard"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"apko allows users to build and publish OCI container images built from apk packages. From version 0.14.8 to before 1.1.1, an attacker who controls or compromises an APK repository used by apko could cause resource exhaustion on the build host. The ExpandApk function in pkg/apk/expandapk/expandapk.go expands .apk streams without enforcing decompression limits, allowing a malicious repository to serve a small, highly-compressed .apk that inflates into a large tar stream, consuming excessive disk space and CPU time, causing build failures or denial of service. This issue has been patched in version 1.1.1.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"apko affected by potential unbounded resource consumption in expandapk.ExpandApk on attacker-controlled .apk streams","id":"CVE-2026-25140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Orval has a code injection via unsanitized x-enum-descriptions uing JS comments","id":"CVE-2026-25141"},"packages":[{"ecosystem":"Go","fixed":["1.1.1"],"introduced":["0.14.8"],"last_affected":[],"package":"chainguard.dev/apko","purl":"pkg:golang/chainguard.dev/apko","source":"GO-2026-4410"}],"prev":{"headline":"RIOT Vulnerable to Multiple Out-of-Bounds Read When Processing Received 6LoWPAN SFR Fragments","id":"CVE-2026-25139"},"products":["apko"],"published":"2026-02-04","related":[{"cvss_score":7.5,"headline":"apko is vulnerable to path traversal in apko dirFS which allows filesystem writes outside base","id":"CVE-2026-25121","kev_date_added":null,"published":"2026-02-04"},{"cvss_score":5.5,"headline":"apko is vulnerable to unbounded resource consumption in expandapk.Split on attacker-controlled .apk streams","id":"CVE-2026-25122","kev_date_added":null,"published":"2026-02-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-04","vendors":["chainguard-dev"]},"summary":"An attacker controlling an APK repository can cause resource exhaustion on the build host by serving highly compressed APK streams, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-25140/"}