# CVE-2026-25140: apko affected by potential unbounded resource consumption in expandapk.ExpandApk on attacker-controlled .apk streams

> An attacker controlling an APK repository can cause resource exhaustion on the build host by serving highly compressed APK streams, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-f4w5-5xv9-85f6, GO-2026-4410, MINI-9q46-75mp-9653

## What is CVE-2026-25140?

CVE-2026-25140 is a high-severity denial of service vulnerability in chainguard-dev apko, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

apko allows users to build and publish OCI container images built from apk packages. From version 0.14.8 to before 1.1.1, an attacker who controls or compromises an APK repository used by apko could cause resource exhaustion on the build host. The ExpandApk function in pkg/apk/expandapk/expandapk.go expands .apk streams without enforcing decompression limits, allowing a malicious repository to serve a small, highly-compressed .apk that inflates into a large tar stream, consuming excessive disk space and CPU time, causing build failures or denial of service. This issue has been patched in version 1.1.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-25140?

1 open source package ship an affected version, including chainguard.dev/apko. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/apko` | Go | From 0.14.8 | 1.1.1 |

Products: Chainguard Apko.

## How do I fix CVE-2026-25140?

Upgrade chainguard.dev/apko to 1.1.1 or later.

## Is CVE-2026-25140 being exploited?

There is no known exploitation of CVE-2026-25140 in the wild and no public exploit code.

## Other vulnerabilities in chainguard-dev apko

- [CVE-2026-25121](https://insights.sbomify.com/CVE-2026-25121/): apko is vulnerable to path traversal in apko dirFS which allows filesystem writes outside base (high 7.5)
- [CVE-2026-25122](https://insights.sbomify.com/CVE-2026-25122/): apko is vulnerable to unbounded resource consumption in expandapk.Split on attacker-controlled .apk streams (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25140 and fix it if it is affected.

What it is: CVE-2026-25140 is a high-severity denial of service vulnerability in chainguard-dev apko, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25140 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainguard.dev/apko (Go): affected from 0.14.8; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25140/ (Markdown: https://insights.sbomify.com/CVE-2026-25140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25140
- OSV: https://osv.dev/vulnerability/CVE-2026-25140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25140/
Summaries are generated and may contain mistakes; the official description above is the record.
