CVE-2026-25141 Orval has a code injection via unsanitized x-enum-descriptions uing JS comments
Attackers can execute arbitrary JavaScript in generated clients via JSFuck techniques bypassing sanitization in Orval.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-25141?
CVE-2026-25141 is a critical code injection vulnerability in orval-labs orval, published on 30 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions starting with 7.19.0 and prior to 7.21.0 and 8.2.0 have an incomplete fix for CVE-2026-23947. While the jsStringEscape function properly handles single quotes ('), double quotes (") and so on, it is still possible to achieve code injection using only a limited set of characters that are currently not escaped. The vulnerability lies in the fact that the application can be forced to execute arbitrary JavaScript using characters such as []()!+. By using a technique known as JSFuck, an attacker can bypass the current sanitization logic and run arbitrary code without needing any alphanumeric characters or quotes. Version 7.21.0 and 8.2.0 contain an updated fix.
Weakness: CWE-94
Which versions are affected by CVE-2026-25141?
4 open source packages ship an affected version, including @orval/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@orval/core npm | From 7.19.0 | 7.21.0 |
@orval/core npm | From 7.19.0 | 7.21.0 |
@orval/core npm | From 8.0.0 | 8.2.0 |
@orval/core npm | From 8.0.0 | 8.2.0 |
Products include Orval Orval.
How do I fix CVE-2026-25141?
Upgrade @orval/core to a fixed version for your release line: 7.21.0 or 8.2.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-25141 being exploited?
There is no known exploitation of CVE-2026-25141 in the wild and no public exploit code.
Other vulnerabilities in orval-labs orval
Sources
Also known as GHSA-gch2-phqh-fg9q.