CVE-2026-25143 melange affected by potential host command execution via license-check YAML mode patch pipeline

High 7.8 Published Updated

Attackers can execute arbitrary shell commands on the build host by injecting metacharacters into melange patch pipeline inputs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-25143?

CVE-2026-25143 is a high-severity command injection vulnerability in chainguard-dev melange, published on 4 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

melange allows users to build apk packages using declarative pipelines. From version 0.10.0 to before 0.40.3, an attacker who can influence inputs to the patch pipeline could execute arbitrary shell commands on the build host. The patch pipeline in pkg/build/pipelines/patch.yaml embeds input-derived values (series paths, patch filenames, and numeric parameters) into shell scripts without proper quoting or validation, allowing shell metacharacters to break out of their intended context. The vulnerability affects the built-in patch pipeline which can be invoked through melange build and melange license-check operations. An attacker who can control patch-related inputs (e.g., through pull request-driven CI, build-as-a-service, or by influencing melange configurations) can inject shell metacharacters such as backticks, command substitutions $(…), semicolons, pipes, or redirections to execute arbitrary commands with the privileges of the melange build process. This issue has been patched in version 0.40.3.

Weakness: CWE-78

Which versions are affected by CVE-2026-25143?

3 open source packages ship an affected version, including chainguard.dev/melange. It affects 1 product.

PackageAffectedFixed in
chainguard.dev/melange GoFrom 0.10.00.40.3
chainguard.dev/melange GoFrom 0.10.00.40.3
chainguard.dev/melange GoFrom 0.10.00.40.3

Products include Chainguard Melange.

How do I fix CVE-2026-25143?

Upgrade chainguard.dev/melange to 0.40.3 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-25143 being exploited?

There is no known exploitation of CVE-2026-25143 in the wild and no public exploit code.

Sources

Also known as GHSA-rf4g-89h5-crcr, GO-2026-4412.

Is CVE-2026-25143 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free