# CVE-2026-25145: melange has a path traversal in license-path which allows reading files outside workspace

> An attacker influencing melange configuration files can read arbitrary host files via path traversal in license paths, exposing sensitive data in build artifacts.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-2w4f-9fgg-q2v9, GO-2026-4409

## What is CVE-2026-25145?

CVE-2026-25145 is a medium-severity path traversal vulnerability in chainguard-dev melange, published on 4 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

melange allows users to build apk packages using declarative pipelines. From version 0.14.0 to before 0.40.3, an attacker who can influence a melange configuration file (e.g., through pull request-driven CI or build-as-a-service scenarios) could read arbitrary files from the host system. The LicensingInfos function in pkg/config/config.go reads license files specified in copyright[].license-path without validating that paths remain within the workspace directory, allowing path traversal via ../ sequences. The contents of the traversed file are embedded into the generated SBOM as license text, enabling exfiltration of sensitive data through build artifacts. This issue has been patched in version 0.40.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-25145?

3 open source packages ship an affected version, including chainguard.dev/melange. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/melange` | Go | From 0.14.0 | 0.40.3 |
| `chainguard.dev/melange` | Go | From 0.14.0 | 0.40.3 |
| `chainguard.dev/melange` | Go | From 0.14.0 | 0.40.3 |

Products: Chainguard Melange.

## How do I fix CVE-2026-25145?

Upgrade chainguard.dev/melange to 0.40.3 or later.

## Is CVE-2026-25145 being exploited?

There is no known exploitation of CVE-2026-25145 in the wild and no public exploit code.

## Other vulnerabilities in chainguard-dev melange

- [CVE-2026-24843](https://insights.sbomify.com/CVE-2026-24843/): melange QEMU runner could write files outside workspace directory (high 8.2)
- [CVE-2026-24844](https://insights.sbomify.com/CVE-2026-24844/): melange pipeline working-directory could allow command injection (high 7.8)
- [CVE-2026-25143](https://insights.sbomify.com/CVE-2026-25143/): melange affected by potential host command execution via license-check YAML mode patch pipeline (high 7.8)
- [CVE-2026-29050](https://insights.sbomify.com/CVE-2026-29050/): melange has Path Traversal When Resolving External Pipelines via Unvalidated pipeline[].uses (medium 6.1)
- [CVE-2026-29051](https://insights.sbomify.com/CVE-2026-29051/): melange has Path Traversal via .PKGINFO in --persist-lint-results (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25145 and fix it if it is affected.

What it is: CVE-2026-25145 is a medium-severity path traversal vulnerability in chainguard-dev melange, published on 4 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25145 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainguard.dev/melange (Go): affected from 0.14.0; fixed in 0.40.3
- chainguard.dev/melange (Go): affected from 0.14.0; fixed in 0.40.3
- chainguard.dev/melange (Go): affected from 0.14.0; fixed in 0.40.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25145/ (Markdown: https://insights.sbomify.com/CVE-2026-25145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25145
- OSV: https://osv.dev/vulnerability/CVE-2026-25145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25145/
Summaries are generated and may contain mistakes; the official description above is the record.
