# CVE-2026-25152: @backstage/plugin-techdocs-node vulnerable to possible Path Traversal in TechDocs Local Generator

> Attackers can read arbitrary host files via symlink traversal in TechDocs local generator when configured to run locally.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2026
- **Updated:** 2 Feb 2026
- **Also known as:** GHSA-w669-jj7h-88m9

## What is CVE-2026-25152?

CVE-2026-25152 is a medium-severity path traversal vulnerability in Linuxfoundation Backstage, published on 30 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals, and @backstage/plugin-techdocs-node provides common node.js functionalities for TechDocs. In versions of @backstage/plugin-techdocs-node prior to 1.13.11 and 1.14.1, a path traversal vulnerability in the TechDocs local generator allows attackers to read arbitrary files from the host filesystem when Backstage is configured with `techdocs.generator.runIn: local`. When processing documentation from untrusted sources, symlinks within the docs directory are followed by MkDocs during the build process. File contents are embedded into generated HTML and exposed to users who can view the documentation. This vulnerability is fixed in` @backstage/plugin-techdocs-node` versions 1.13.11 and 1.14.1. Some workarounds are available. Switch to `runIn: docker` in `app-config.yaml` and/or restrict write access to TechDocs source repositories to trusted users only.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-25152?

4 open source packages ship an affected version, including @backstage/plugin-techdocs-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.13.11 |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.13.11 |
| `@backstage/plugin-techdocs-node` | npm | From 1.14.0 | 1.14.1 |
| `@backstage/plugin-techdocs-node` | npm | From 1.14.0 | 1.14.1 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2026-25152?

Upgrade @backstage/plugin-techdocs-node to a fixed version for your release line: 1.13.11 or 1.14.1.

## Is CVE-2026-25152 being exploited?

There is no known exploitation of CVE-2026-25152 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25152 and fix it if it is affected.

What it is: CVE-2026-25152 is a medium-severity path traversal vulnerability in Linuxfoundation Backstage, published on 30 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25152 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.13.11
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.13.11
- @backstage/plugin-techdocs-node (npm): affected from 1.14.0; fixed in 1.14.1
- @backstage/plugin-techdocs-node (npm): affected from 1.14.0; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25152/ (Markdown: https://insights.sbomify.com/CVE-2026-25152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25152
- OSV: https://osv.dev/vulnerability/CVE-2026-25152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25152/
Summaries are generated and may contain mistakes; the official description above is the record.
