# CVE-2026-25153: @backstage/plugin-techdocs-node vulnerable to arbitrary code execution via MkDocs hooks

> Attackers can execute arbitrary Python code on the build server by modifying mkdocs.yml hooks when TechDocs runs locally.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-6jr7-99pf-8vgf

## What is CVE-2026-25153?

CVE-2026-25153 is a high-severity code injection vulnerability in Linuxfoundation Backstage, published on 30 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals, and @backstage/plugin-techdocs-node provides common node.js functionalities for TechDocs. In versions of @backstage/plugin-techdocs-node prior to 1.13.11 and 1.14.1, when TechDocs is configured with `runIn: local`, a malicious actor who can submit or modify a repository's `mkdocs.yml` file can execute arbitrary Python code on the TechDocs build server via MkDocs hooks configuration. @backstage/plugin-techdocs-node versions 1.13.11 and 1.14.1 contain a fix. The fix introduces an allowlist of supported MkDocs configuration keys. Unsupported configuration keys (including `hooks`) are now removed from `mkdocs.yml` before running the generator, with a warning logged to indicate which keys were removed. Users of `@techdocs/cli` should also upgrade to the latest version, which includes the fixed `@backstage/plugin-techdocs-node` dependency. Some workarounds are available. Configure TechDocs with `runIn: docker` instead of `runIn: local` to provide container isolation, though it does not fully mitigate the risk. Limit who can modify `mkdocs.yml` files in repositories that TechDocs processes; only allow trusted contributors. Implement PR review requirements for changes to `mkdocs.yml` files to detect malicious `hooks` configurations before they are merged. Use MkDocs < 1.4.0 (e.g., 1.3.1) which does not support hooks. Note: This may limit access to newer MkDocs features. Building documentation in CI/CD pipelines using `@techdocs/cli` does not mitigate this vulnerability, as the CLI uses the same vulnerable `@backstage/plugin-techdocs-node` package.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-25153?

4 open source packages ship an affected version, including @backstage/plugin-techdocs-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.13.11 |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.13.11 |
| `@backstage/plugin-techdocs-node` | npm | From 1.14.0 | 1.14.1 |
| `@backstage/plugin-techdocs-node` | npm | From 1.14.0 | 1.14.1 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2026-25153?

Upgrade @backstage/plugin-techdocs-node to a fixed version for your release line: 1.13.11 or 1.14.1.

## Is CVE-2026-25153 being exploited?

There is no known exploitation of CVE-2026-25153 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25153 and fix it if it is affected.

What it is: CVE-2026-25153 is a high-severity code injection vulnerability in Linuxfoundation Backstage, published on 30 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25153 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.13.11
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.13.11
- @backstage/plugin-techdocs-node (npm): affected from 1.14.0; fixed in 1.14.1
- @backstage/plugin-techdocs-node (npm): affected from 1.14.0; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25153/ (Markdown: https://insights.sbomify.com/CVE-2026-25153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25153
- OSV: https://osv.dev/vulnerability/CVE-2026-25153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25153/
Summaries are generated and may contain mistakes; the official description above is the record.
