# CVE-2026-25157: OpenClaw/Clawdbot has OS Command Injection via Project Root Path in sshNodeCommand

> OpenClaw allows OS command injection via unescaped project paths and SSH target arguments, enabling arbitrary code execution on local and remote hosts.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-q284-4pvr-m585

## What is CVE-2026-25157?

CVE-2026-25157 is a high-severity command injection vulnerability in Openclaw Openclaw, published on 4 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw is a personal AI assistant. Prior to version 2026.1.29, there is an OS command injection vulnerability via the Project Root Path in sshNodeCommand. The sshNodeCommand function constructed a shell script without properly escaping the user-supplied project path in an error message. When the cd command failed, the unescaped path was interpolated directly into an echo statement, allowing arbitrary command execution on the remote SSH host. The parseSSHTarget function did not validate that SSH target strings could not begin with a dash. An attacker-supplied target like -oProxyCommand=... would be interpreted as an SSH configuration flag rather than a hostname, allowing arbitrary command execution on the local machine. This issue has been patched in version 2026.1.29.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-25157?

2 open source packages ship an affected version, including clawdbot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `clawdbot` | npm | All versions | 2026.1.29 |
| `clawdbot` | npm | All versions | 2026.1.29 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-25157?

Upgrade clawdbot to 2026.1.29 or later.

## Is CVE-2026-25157 being exploited?

There is no known exploitation of CVE-2026-25157 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25157 and fix it if it is affected.

What it is: CVE-2026-25157 is a high-severity command injection vulnerability in Openclaw Openclaw, published on 4 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25157 in the wild and no public exploit code.

Affected packages and fixed versions:
- clawdbot (npm): affected all versions; fixed in 2026.1.29
- clawdbot (npm): affected all versions; fixed in 2026.1.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25157/ (Markdown: https://insights.sbomify.com/CVE-2026-25157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25157
- OSV: https://osv.dev/vulnerability/CVE-2026-25157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25157/
Summaries are generated and may contain mistakes; the official description above is the record.
