# CVE-2026-25198: web2py has an Open Redirect Vulnerability

> Attackers can redirect users to malicious sites via crafted URLs, facilitating phishing attacks against web2py users.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-rf8c-3f5p-xv45, PYSEC-2026-3413, UBUNTU-CVE-2026-25198

## What is CVE-2026-25198?

CVE-2026-25198 is a medium-severity vulnerability in web2py, published on 5 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

web2py versions 2.27.1-stable+timestamp.2023.11.16.08.03.57 and prior contain an open redirect vulnerability. If this vulnerability is exploited, the user may be redirected to an arbitrary website when accessing a specially crafted URL. As a result, the user may become a victim of a phishing attack.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-25198?

3 open source packages ship an affected version, including web2py.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `web2py` | PyPI | All versions | 3.1.1 |
| `web2py` | PyPI | All versions | 3.1.1 |
| `web2py` | PyPI | All versions | 3.1.1 |

## How do I fix CVE-2026-25198?

Upgrade web2py to 3.1.1 or later.

## Is CVE-2026-25198 being exploited?

There is no known exploitation of CVE-2026-25198 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25198 and fix it if it is affected.

What it is: CVE-2026-25198 is a medium-severity vulnerability in web2py, published on 5 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25198 in the wild and no public exploit code.

Affected packages and fixed versions:
- web2py (PyPI): affected all versions; fixed in 3.1.1
- web2py (PyPI): affected all versions; fixed in 3.1.1
- web2py (PyPI): affected all versions; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25198/ (Markdown: https://insights.sbomify.com/CVE-2026-25198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25198
- OSV: https://osv.dev/vulnerability/CVE-2026-25198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25198/
Summaries are generated and may contain mistakes; the official description above is the record.
