# CVE-2026-25199: Apache CloudStack: Proxmox Extension Allows Unauthorized Cross-Tenant Instance Access

> Attackers can modify instance settings to gain unauthorized control over other tenants' virtual machines in Apache CloudStack with the Proxmox extension.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 9 May 2026
- **Also known as:** GHSA-whfq-93mc-cv6g

## What is CVE-2026-25199?

CVE-2026-25199 is a critical missing authorization vulnerability in Apache Cloudstack, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Instances deployed via the Proxmox extension allow unauthorized access to instances belonging to other tenants.

This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.0.0.

The Proxmox extension for CloudStack improperly uses a user-editable instance setting, proxmox_vmid, to associate CloudStack instances with Proxmox virtual machines. Because this value is not restricted or validated against tenant ownership and Proxmox VM IDs are predictable, a non-privileged attacker can modify the setting to reference a VM belonging to another account. This allows unauthorized cross-tenant access and enables full control over the targeted VM, including starting, stopping, and destroying the virtual machine.

Users are recommended to upgrade to version 4.22.0.1, which fixes this issue.

As a workaround for the existing installations, editing of the proxmox_vmid instance detail by users can be prevented by adding this detail name to the global configuration parameter - user.vm.denied.details.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-25199?

It affects 1 product.


Products: Apache Cloudstack.

## How do I fix CVE-2026-25199?

No fix has been published for CVE-2026-25199 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-25199 being exploited?

There is no known exploitation of CVE-2026-25199 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cloudstack

- [CVE-2012-4501](https://insights.sbomify.com/CVE-2012-4501/): Missing authorization in n/a (critical 10.0)
- [CVE-2024-38346](https://insights.sbomify.com/CVE-2024-38346/): Apache CloudStack: Unauthenticated cluster service port leads to remote execution (critical 9.8)
- [CVE-2024-39864](https://insights.sbomify.com/CVE-2024-39864/): Apache CloudStack: Integration API service uses dynamic port when disabled (critical 9.8)
- [CVE-2024-29006](https://insights.sbomify.com/CVE-2024-29006/): Apache CloudStack: x-forwarded-for HTTP header parsed by default (critical 9.8)
- [CVE-2022-35741](https://insights.sbomify.com/CVE-2022-35741/): Apache CloudStack SAML Single Sign-On XXE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25199 and fix it if it is affected.

What it is: CVE-2026-25199 is a critical missing authorization vulnerability in Apache Cloudstack, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25199 in the wild and no public exploit code.

Affected product: Apache Cloudstack. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25199/ (Markdown: https://insights.sbomify.com/CVE-2026-25199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25199
- OSV: https://osv.dev/vulnerability/CVE-2026-25199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25199/
Summaries are generated and may contain mistakes; the official description above is the record.
