{"answers":{"affected":"3 open source packages ship an affected version, including llama-stack.","exploited":"There is no known exploitation of CVE-2026-25211 in the wild and no public exploit code.","fix":"Upgrade llama-stack to 0.4.4 or later.","what":"CVE-2026-25211 is a low-severity vulnerability in llamastack Llama Stack, published on 30 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-25211 and fix it if it is affected.\n\nWhat it is: CVE-2026-25211 is a low-severity vulnerability in llamastack Llama Stack, published on 30 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-25211 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- llama-stack (PyPI): affected all versions; fixed in 0.4.4\n- llama-stack (PyPI): affected all versions; fixed in 0.4.4\n- llama-stack (PyPI): affected all versions; fixed in 0.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-25211/ (Markdown: https://insights.sbomify.com/CVE-2026-25211/index.md)","id":"CVE-2026-25211","markdown":"https://insights.sbomify.com/CVE-2026-25211/index.md","name":"CVE-2026-25211","record":{"aliases":["GHSA-xmfj-7pp5-fxr6","PYSEC-2026-1572"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Llama Stack library","requires_auth":"none","summary":"Attackers can read the pgvector password from initialization logs, exposing database credentials in Llama Stack deployments.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":3.2,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-01-31","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-01-31T22:42:09Z","kind":"github_poc","ref":"https://github.com/mbanyamer/Llama-Stack-0.4.0rc3-local-CVE-2026-25211","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Llama Stack exposes secret in initialization log","id":"CVE-2026-25211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2026-25212"},"packages":[{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"llama-stack","purl":null,"source":"GHSA-xmfj-7pp5-fxr6"},{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"llama-stack","purl":"pkg:pypi/llama-stack","source":"GHSA-xmfj-7pp5-fxr6"},{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"llama-stack","purl":"pkg:pypi/llama-stack","source":"PYSEC-2026-1572"}],"prev":{"headline":"Integer overflow in libexpat","id":"CVE-2026-25210"},"products":["Llama Stack"],"published":"2026-01-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-03","vendors":["llamastack"]},"summary":"Attackers can read the pgvector password from initialization logs, exposing database credentials in Llama Stack deployments.","url":"https://insights.sbomify.com/CVE-2026-25211/"}