# CVE-2026-25211: Llama Stack exposes secret in initialization log

> Attackers can read the pgvector password from initialization logs, exposing database credentials in Llama Stack deployments.

- **Severity:** Low 3.2 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2026
- **Updated:** 3 Feb 2026
- **Also known as:** GHSA-xmfj-7pp5-fxr6, PYSEC-2026-1572

## What is CVE-2026-25211?

CVE-2026-25211 is a low-severity vulnerability in llamastack Llama Stack, published on 30 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-25211?

3 open source packages ship an affected version, including llama-stack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-stack` | PyPI | All versions | 0.4.4 |
| `llama-stack` | PyPI | All versions | 0.4.4 |
| `llama-stack` | PyPI | All versions | 0.4.4 |

## How do I fix CVE-2026-25211?

Upgrade llama-stack to 0.4.4 or later.

## Is CVE-2026-25211 being exploited?

There is no known exploitation of CVE-2026-25211 in the wild and no public exploit code.

Public exploit code:

- https://github.com/mbanyamer/Llama-Stack-0.4.0rc3-local-CVE-2026-25211 (github_poc): https://github.com/mbanyamer/Llama-Stack-0.4.0rc3-local-CVE-2026-25211

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25211 and fix it if it is affected.

What it is: CVE-2026-25211 is a low-severity vulnerability in llamastack Llama Stack, published on 30 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25211 in the wild and no public exploit code.

Affected packages and fixed versions:
- llama-stack (PyPI): affected all versions; fixed in 0.4.4
- llama-stack (PyPI): affected all versions; fixed in 0.4.4
- llama-stack (PyPI): affected all versions; fixed in 0.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25211/ (Markdown: https://insights.sbomify.com/CVE-2026-25211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25211
- OSV: https://osv.dev/vulnerability/CVE-2026-25211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25211/
Summaries are generated and may contain mistakes; the official description above is the record.
