# CVE-2026-25219: Apache Airlfow: Sensitive Azure Service Bus connection string (and possibly other providers) exposed to users with view access

> Users with view access can expose sensitive Azure Service Bus connection strings in the UI and logs due to missing secret masking.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** BIT-airflow-2026-25219, ECHO-0aa9-b91a-8ef7, GHSA-4g48-54q2-fg7q, MINI-5fcj-c3cc-hr35, MINI-hp59-jh52-q444, PYSEC-2026-2344

## What is CVE-2026-25219?

CVE-2026-25219 is a medium-severity vulnerability in Apache Airflow, published on 15 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The `access_key` and `connection_string` connection properties were not marked as sensitive names in secrets masker. This means that user with read permission could see the values in Connection UI, as well as when Connection was accidentaly logged to logs, those values could be seen in the logs. Azure Service Bus used those properties to store sensitive values. Possibly other providers could be also affected if they used the same fields to store sensitive data.

If you used Azure Service Bus connection with those values set or if you have other connections with those values storing sensitve values, you should upgrade Airflow to 3.1.8

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-25219?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.1.8 |
| `apache-airflow` | PyPI | All versions | 3.1.8 |
| `apache-airflow` | PyPI | All versions | 3.1.8 |
| `airflow` | Bitnami | All versions | 3.1.8 |

Products: Apache Airflow.

## How do I fix CVE-2026-25219?

Upgrade apache-airflow to 3.1.8 or later.

## Is CVE-2026-25219 being exploited?

There is no known exploitation of CVE-2026-25219 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25219 and fix it if it is affected.

What it is: CVE-2026-25219 is a medium-severity vulnerability in Apache Airflow, published on 15 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25219 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.1.8
- apache-airflow (PyPI): affected all versions; fixed in 3.1.8
- apache-airflow (PyPI): affected all versions; fixed in 3.1.8
- airflow (Bitnami): affected all versions; fixed in 3.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25219/ (Markdown: https://insights.sbomify.com/CVE-2026-25219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25219
- OSV: https://osv.dev/vulnerability/CVE-2026-25219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25219/
Summaries are generated and may contain mistakes; the official description above is the record.
