# CVE-2026-25232: Gogs has a Protected Branch Deletion Bypass in Web Interface

> Collaborators with write access can delete protected branches via the web interface, bypassing protection mechanisms and escalating privileges.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-2c6v-8r3v-gh6p, GO-2026-4498

## What is CVE-2026-25232?

CVE-2026-25232 is a high-severity missing authorization vulnerability in gogs, published on 19 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. Versions 0.13.4 and below have an access control bypass vulnerability which allows any repository collaborator with Write permissions to delete protected branches (including the default branch) by sending a direct POST request, completely bypassing the branch protection mechanism. This vulnerability in the DeleteBranchPost function eenables privilege escalation from Write to Admin level, allowing low-privilege users to perform dangerous operations that should be restricted to administrators only. Although Git Hook layer correctly prevents protected branch deletion via SSH push, the web interface deletion operation does not trigger Git Hooks, resulting in complete bypass of protection mechanisms. In oder to exploit this vulnerability, attackers must have write permissions to the target repository, protected branches configured to the target repository and access to the Gogs web interface. This issue has been fixed in version 0.14.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-25232?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | None |
| `gogs.io/gogs` | Go | All versions | 0.14.1 |
| `gogs.io/gogs` | Go | All versions | 0.14.1 |

Products: Gogs Gogs.

## How do I fix CVE-2026-25232?

Upgrade gogs.io/gogs to 0.14.1 or later.

## Is CVE-2026-25232 being exploited?

There is no known exploitation of CVE-2026-25232 in the wild and no public exploit code.

Public exploit code:

- Proof of concept for the recent CVE-2026-25232 which is a priv esc vulnerability present in Gogs.  (github_poc): https://github.com/H1sok444/CVE-2026-25232-PoC

## Other vulnerabilities in gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25232 and fix it if it is affected.

What it is: CVE-2026-25232 is a high-severity missing authorization vulnerability in gogs, published on 19 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25232 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; no fix listed
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.1
- gogs.io/gogs (Go): affected all versions; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25232/ (Markdown: https://insights.sbomify.com/CVE-2026-25232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25232
- OSV: https://osv.dev/vulnerability/CVE-2026-25232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25232/
Summaries are generated and may contain mistakes; the official description above is the record.
