# CVE-2026-25492: Craft has a save_images_Asset graphql mutation can be abused to exfiltrate AWS credentials of underlying host

> Authenticated attackers can exploit a GraphQL mutation to bypass validation and exfiltrate sensitive AWS credentials from the underlying host via SSRF.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-96pq-hxpw-rgh8

## What is CVE-2026-25492?

CVE-2026-25492 is a medium-severity server-side request forgery vulnerability in Craftcms Craft Cms, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS is a content management system. In Craft versions 3.5.0 through 4.16.17 and 5.0.0-RC1 through 5.8.21, the save_images_Asset GraphQL mutation can be abused to fetch internal URLs by providing a domain name that resolves to an internal IP address, bypassing hostname validation. When a non-image file extension such as .txt is allowed, downstream image validation is bypassed, which can allow an authenticated attacker with permission to use save_images_Asset to retrieve sensitive data such as AWS instance metadata credentials from the underlying host. This issue is patched in versions 4.16.18 and 5.8.22.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-25492?

4 open source packages ship an affected version, including craftcms/craft. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/craft` | Packagist | From 3.5.0 | 4.16.18 |
| `craftcms/craft` | Packagist | From 3.5.0 | 4.16.18 |
| `craftcms/craft` | Packagist | From 5.0.0-RC1 | 5.8.22 |
| `craftcms/craft` | Packagist | From 5.0.0-RC1 | 5.8.22 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-25492?

Upgrade craftcms/craft to a fixed version for your release line: 4.16.18 or 5.8.22.

## Is CVE-2026-25492 being exploited?

There is no known exploitation of CVE-2026-25492 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25492 and fix it if it is affected.

What it is: CVE-2026-25492 is a medium-severity server-side request forgery vulnerability in Craftcms Craft Cms, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25492 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/craft (Packagist): affected from 3.5.0; fixed in 4.16.18
- craftcms/craft (Packagist): affected from 3.5.0; fixed in 4.16.18
- craftcms/craft (Packagist): affected from 5.0.0-RC1; fixed in 5.8.22
- craftcms/craft (Packagist): affected from 5.0.0-RC1; fixed in 5.8.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25492/ (Markdown: https://insights.sbomify.com/CVE-2026-25492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25492
- OSV: https://osv.dev/vulnerability/CVE-2026-25492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25492/
Summaries are generated and may contain mistakes; the official description above is the record.
