# CVE-2026-25497: Craft has a GraphQL Asset Mutation Privilege Escalation

> Authenticated users can escalate privileges to modify or transfer assets in restricted volumes via GraphQL API flaws in Craft CMS.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** GHSA-fxp3-g6gw-4r4v

## What is CVE-2026-25497?

CVE-2026-25497 is a high-severity vulnerability in Craftcms Craft Cms, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft is a platform for creating digital experiences. In Craft versions from 4.0.0-RC1 to before 4.17.0-beta.1 and 5.9.0-beta.1, there is a Privilege Escalation vulnerability in Craft CMS’s GraphQL API that allows an authenticated user with write access to one asset volume to escalate their privileges and modify/transfer assets belonging to any other volume, including restricted or private volumes to which they should not have access. The saveAsset GraphQL mutation validates authorization against the schema-resolved volume but fetches the target asset by ID without verifying that the asset belongs to the authorized volume. This allows unauthorized cross-volume asset modification and transfer. This vulnerability is fixed in 4.17.0-beta.1 and 5.9.0-beta.1.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-25497?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.0-beta.1 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-25497?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.0-beta.1 or 5.9.0-beta.1.

## Is CVE-2026-25497 being exploited?

There is no known exploitation of CVE-2026-25497 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25497 and fix it if it is affected.

What it is: CVE-2026-25497 is a high-severity vulnerability in Craftcms Craft Cms, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25497 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.0-beta.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25497/ (Markdown: https://insights.sbomify.com/CVE-2026-25497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25497
- OSV: https://osv.dev/vulnerability/CVE-2026-25497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25497/
Summaries are generated and may contain mistakes; the official description above is the record.
