# CVE-2026-25500: Rack's Stored XSS in Rack::Directory via javascript: filenames rendered into anchor href

> Attackers can execute arbitrary JavaScript in victim browsers by placing files with javascript: names in directories served by Rack::Directory.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Feb 2026
- **Updated:** 18 Feb 2026
- **Also known as:** CLEANSTART-2026-IX45302, CLEANSTART-2026-ZK59017, DEBIAN-CVE-2026-25500, GHSA-whrj-4476-wvmp, MINI-245w-r8vc-rxp3, MINI-285j-m8h2-77m4, MINI-2j29-h6c2-4x94, MINI-3565-459v-qg35, MINI-3xmc-cc2j-8xp2, MINI-853p-5r44-r9cr, MINI-85r6-8v58-9xjh, MINI-9473-7v68-fwh8, MINI-cq3h-456p-gp46, MINI-g4xg-wm27-865j, MINI-gcgv-7335-2w5w, MINI-gjxr-2h7c-mjgp, MINI-gq5p-jwhq-7ccr, MINI-h2fx-xcp4-gjr5, MINI-h37r-r65w-2vcx, MINI-h3fq-f84f-7gg8, MINI-hm9g-98wj-v3r2, MINI-j7q7-fmpc-6qf8, MINI-jv42-3rv8-fvhq, MINI-r5j6-jh5f-j8hj, MINI-rj79-c5jg-45hx, MINI-vwj3-w4jg-vhfm, UBUNTU-CVE-2026-25500

## What is CVE-2026-25500?

CVE-2026-25500 is a medium-severity cross-site scripting vulnerability in rack, published on 18 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.22, 3.1.20, and 3.2.5, `Rack::Directory` generates an HTML directory index where each file entry is rendered as a clickable link. If a file exists on disk whose basename starts with the `javascript:` scheme (e.g. `javascript:alert(1)`), the generated index contains an anchor whose `href` is exactly `javascript:alert(1)`. Clicking the entry executes JavaScript in the browser (demonstrated with `alert(1)`). Versions 2.2.22, 3.1.20, and 3.2.5 fix the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25500?

6 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.22 |
| `rack` | RubyGems | All versions | 2.2.22 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.20 |
| `rack` | RubyGems | From 3.0.0.beta1 | 3.1.20 |
| `rack` | RubyGems | From 3.2.0 | 3.2.5 |
| `rack` | RubyGems | From 3.2.0 | 3.2.5 |

Products: Rack Rack.

## How do I fix CVE-2026-25500?

Upgrade rack to a fixed version for your release line: 2.2.22, 3.1.20 or 3.2.5.

## Is CVE-2026-25500 being exploited?

There is no known exploitation of CVE-2026-25500 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25500 and fix it if it is affected.

What it is: CVE-2026-25500 is a medium-severity cross-site scripting vulnerability in rack, published on 18 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25500 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.22
- rack (RubyGems): affected all versions; fixed in 2.2.22
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.20
- rack (RubyGems): affected from 3.0.0.beta1; fixed in 3.1.20
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.5
- rack (RubyGems): affected from 3.2.0; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25500/ (Markdown: https://insights.sbomify.com/CVE-2026-25500/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25500
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25500
- OSV: https://osv.dev/vulnerability/CVE-2026-25500

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25500/
Summaries are generated and may contain mistakes; the official description above is the record.
