# CVE-2026-25510: CI4MS Vulnerable to Remote Code Execution (RCE) via Arbitrary File Creation and Save in File Editor

> Authenticated users with file editor permissions can achieve remote code execution by uploading and executing arbitrary PHP code via file editor endpoints.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-gp56-f67f-m4px

## What is CVE-2026-25510?

CVE-2026-25510 is a critical code injection vulnerability in ci4-cms-erp ci4ms, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.28.5.0, an authenticated user with file editor permissions can achieve Remote Code Execution (RCE) by leveraging the file creation and save endpoints, an attacker can upload and execute arbitrary PHP code on the server. This issue has been patched in version 0.28.5.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-25510?

2 open source packages ship an affected version, including ci4-cms-erp/ci4ms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.28.5.0 |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.28.5.0 |

Products: Ci4-Cms-Erp Ci4ms.

## How do I fix CVE-2026-25510?

Upgrade ci4-cms-erp/ci4ms to 0.28.5.0 or later.

## Is CVE-2026-25510 being exploited?

There is no known exploitation of CVE-2026-25510 in the wild and no public exploit code.

## Other vulnerabilities in ci4-cms-erp ci4ms

- [CVE-2026-34569](https://insights.sbomify.com/CVE-2026-34569/): CI4MS: Blogs Categories Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS (critical 10.0)
- [CVE-2026-34571](https://insights.sbomify.com/CVE-2026-34571/): CI4MS: Stored Cross‑Site Scripting (Stored XSS) in Backend User Management Allows Session Hijacking and Full Administrative Account Compromise (critical 10.0)
- [CVE-2026-34989](https://insights.sbomify.com/CVE-2026-34989/): CI4MS: Profile & User Management Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS (critical 9.4)
- [CVE-2026-34559](https://insights.sbomify.com/CVE-2026-34559/): CI4MS: Blogs Tags Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS (critical 9.1)
- [CVE-2026-34560](https://insights.sbomify.com/CVE-2026-34560/): CI4MS: Logs Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25510 and fix it if it is affected.

What it is: CVE-2026-25510 is a critical code injection vulnerability in ci4-cms-erp ci4ms, published on 3 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25510 in the wild and no public exploit code.

Affected packages and fixed versions:
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.28.5.0
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.28.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25510/ (Markdown: https://insights.sbomify.com/CVE-2026-25510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25510
- OSV: https://osv.dev/vulnerability/CVE-2026-25510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25510/
Summaries are generated and may contain mistakes; the official description above is the record.
