CVE-2026-25511 Group-Office is vulnerable to SSRF and File Read in WOPI service discovery
Authenticated administrators can exploit SSRF in WOPI discovery to read internal files and exfiltrate data via debug output.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-25511?
CVE-2026-25511 is a high-severity server-side request forgery vulnerability in Intermesh groupoffice, published on 4 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Group-Office is an enterprise customer relationship management and groupware tool. Prior to versions 6.8.150, 25.0.82, and 26.0.5, an authenticated user within the System Administrator group can trigger a full SSRF via the WOPI service discovery URL, including access to internal hosts/ports. The SSRF response body can be exfiltrated via the built‑in debug system, turning it into a visible SSRF. This also allows full server-side file read. This issue has been patched in versions 6.8.150, 25.0.82, and 26.0.5.
Weakness: CWE-918
Which versions are affected by CVE-2026-25511?
It affects 1 product.
Products include Group-Office Group Office.
How do I fix CVE-2026-25511?
No fix has been published for CVE-2026-25511 yet. Limit exposure of the affected software until one is available.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-25511 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-25511 exists.
Other vulnerabilities in Intermesh groupoffice
- CVE-2026-25512 Group-Office is vulnerable to RCE due to Command Injection via TNEF Attachment Handler
- CVE-2026-25134 Group-Office Argument Injection in MaintenanceController::actionZipLanguage
- CVE-2025-63406 Code injection in n/a
- CVE-2023-46730 Server-Side Request Forgery in groupoffice
- CVE-2025-25191 Group-Office has a Stored XSS Vulnerability via user's name field
Sources
Also known as GHSA-r9v4-jm2r-r9pm.