# CVE-2026-25513: FacturaScripts has SQL Injection vulnerability in API ORDER BY Clause

> Authenticated users can execute arbitrary SQL queries via the sort parameter in the REST API, potentially accessing or modifying data.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 5 Feb 2026
- **Also known as:** GHSA-cjfx-qhwm-hf99

## What is CVE-2026-25513?

CVE-2026-25513 is a high-severity SQL injection vulnerability in NeoRazorX facturascripts, published on 4 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FacturaScripts is open-source enterprise resource planning and accounting software. Prior to version 2025.81, FacturaScripts contains a critical SQL injection vulnerability in the REST API that allows authenticated API users to execute arbitrary SQL queries through the sort parameter. The vulnerability exists in the ModelClass::getOrderBy() method where user-supplied sorting parameters are directly concatenated into the SQL ORDER BY clause without validation or sanitization. This affects all API endpoints that support sorting functionality. This issue has been patched in version 2025.81.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic), CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-20 (Improper Input Validation), CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2026-25513?

2 open source packages ship an affected version, including facturascripts/facturascripts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `facturascripts/facturascripts` | Packagist | All versions | 2025.81 |
| `facturascripts/facturascripts` | Packagist | All versions | 2025.81 |

Products: Facturascripts Facturascripts.

## How do I fix CVE-2026-25513?

Upgrade facturascripts/facturascripts to 2025.81 or later.

## Is CVE-2026-25513 being exploited?

There is no known exploitation of CVE-2026-25513 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-25513 - FacturaScripts has SQL Injection in API ORDER BY Clause (github_poc): https://github.com/lukasz-rybak/CVE-2026-25513

## Other vulnerabilities in NeoRazorX facturascripts

- [CVE-2022-1571](https://insights.sbomify.com/CVE-2022-1571/): Cross-site scripting - Reflected in Create Subaccount in neorazorx/facturascripts (critical 9.9)
- [CVE-2022-1715](https://insights.sbomify.com/CVE-2022-1715/): Account Takeover in neorazorx/facturascripts (critical 9.8)
- [CVE-2022-1682](https://insights.sbomify.com/CVE-2022-1682/): Reflected Xss using url based payload in neorazorx/facturascripts (critical 9.4)
- [CVE-2022-1514](https://insights.sbomify.com/CVE-2022-1514/): Stored XSS via upload plugin functionality in zip format in neorazorx/facturascripts (critical 9.0)
- [CVE-2022-1457](https://insights.sbomify.com/CVE-2022-1457/): Store XSS in title parameter executing at EditUser Page & EditProducto page in neorazorx/facturascripts (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25513 and fix it if it is affected.

What it is: CVE-2026-25513 is a high-severity SQL injection vulnerability in NeoRazorX facturascripts, published on 4 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-25513 in the wild and no public exploit code.

Affected packages and fixed versions:
- facturascripts/facturascripts (Packagist): affected all versions; fixed in 2025.81
- facturascripts/facturascripts (Packagist): affected all versions; fixed in 2025.81

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25513/ (Markdown: https://insights.sbomify.com/CVE-2026-25513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25513
- OSV: https://osv.dev/vulnerability/CVE-2026-25513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25513/
Summaries are generated and may contain mistakes; the official description above is the record.
