# CVE-2026-25516: NiceGUI's XSS vulnerability in ui.markdown() allows arbitrary JavaScript execution through unsanitized HTML content

> Attackers can execute arbitrary JavaScript via unsanitized HTML in NiceGUI's markdown component, affecting applications rendering user-controlled content.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 9 Feb 2026
- **Also known as:** GHSA-v82v-c5x8-w282, PYSEC-2026-2231

## What is CVE-2026-25516?

CVE-2026-25516 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NiceGUI is a Python-based UI framework. The ui.markdown() component uses the markdown2 library to convert markdown content to HTML, which is then rendered via innerHTML. By default, markdown2 allows raw HTML to pass through unchanged. This means that if an application renders user-controlled content through ui.markdown(), an attacker can inject malicious HTML containing JavaScript event handlers. Unlike other NiceGUI components that render HTML (ui.html(), ui.chat_message(), ui.interactive_image()), the ui.markdown() component does not provide or require a sanitize parameter, leaving applications vulnerable to XSS attacks. This vulnerability is fixed in 3.7.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-25516?

3 open source packages ship an affected version, including nicegui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nicegui` | PyPI | All versions | 3.7.0 |
| `nicegui` | PyPI | All versions | 3.7.0 |
| `nicegui` | PyPI | All versions | 3.7.0 |

Products: Zauberzeug Nicegui.

## How do I fix CVE-2026-25516?

Upgrade nicegui to 3.7.0 or later.

## Is CVE-2026-25516 being exploited?

There is no known exploitation of CVE-2026-25516 in the wild and no public exploit code.

## Other vulnerabilities in zauberzeug nicegui

- [CVE-2026-25732](https://insights.sbomify.com/CVE-2026-25732/): NiceGUI's Path Traversal via Unsanitized FileUpload.name Enables Arbitrary File Write (high 7.5)
- [CVE-2025-66645](https://insights.sbomify.com/CVE-2025-66645/): NiceGUI Path Traversal Vulnerability in app.add_media_files() Allows Arbitrary File Reading (high 7.5)
- [CVE-2026-21873](https://insights.sbomify.com/CVE-2026-21873/): Zero-click XSS in all NiceGUI apps which uses `ui.sub_pages` (high 7.2)
- [CVE-2026-33332](https://insights.sbomify.com/CVE-2026-33332/): NiceGUI's unvalidated chunk size parameter in media routes can cause memory exhaustion (medium 6.9)
- [CVE-2026-27156](https://insights.sbomify.com/CVE-2026-27156/): NiceGUI has XSS via Code Injection (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-25516 and fix it if it is affected.

What it is: CVE-2026-25516 is a medium-severity cross-site scripting vulnerability in zauberzeug nicegui, published on 6 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-25516 in the wild and no public exploit code.

Affected packages and fixed versions:
- nicegui (PyPI): affected all versions; fixed in 3.7.0
- nicegui (PyPI): affected all versions; fixed in 3.7.0
- nicegui (PyPI): affected all versions; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-25516/ (Markdown: https://insights.sbomify.com/CVE-2026-25516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-25516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-25516
- OSV: https://osv.dev/vulnerability/CVE-2026-25516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-25516/
Summaries are generated and may contain mistakes; the official description above is the record.
